Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » error at building Open62541 with Cmake(Help solving this error)
error at building Open62541 with Cmake [message #1769636] Wed, 02 August 2017 10:47 Go to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
hello, guys,

i meet a Problem, that a error happened at building Open62541 with Cmake GUI to integrate the opc ua in Forte and communicate with 4diac. The error is Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) and other errors are putted in attachment.
  • Attachment: Fehler2.PNG
    (Size: 57.85KB, Downloaded 26 times)
Re: error at building Open62541 with Cmake [message #1769639 is a reply to message #1769636] Wed, 02 August 2017 11:04 Go to previous messageGo to next message
Stefan Profanter is currently offline Stefan ProfanterFriend
Messages: 11
Registered: July 2017
Junior Member
Hi Fei Yin,
you need to install Python on your machine.

The easiest way is to use the installer from here:
https://www.python.org/downloads/

We recommend using Python 2.7

BR
Stefan
Re: error at building Open62541 with Cmake [message #1769641 is a reply to message #1769639] Wed, 02 August 2017 11:10 Go to previous messageGo to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
Thank you, Stefan,

with your suggestion i have solved this error, but another error happened. You can see this error,that is Could NOT find Sphinx, in attachment.
  • Attachment: Fehler3.PNG
    (Size: 17.07KB, Downloaded 22 times)
Re: error at building Open62541 with Cmake [message #1769642 is a reply to message #1769639] Wed, 02 August 2017 11:11 Go to previous messageGo to next message
Fei  Yin is currently offline Fei YinFriend
Messages: 36
Registered: July 2017
Member
Thank you, Stefan,

with your suggestion i have solved this error, but another error happened. You can see this error,that is Could NOT find Sphinx, in attachment.
Re: error at building Open62541 with Cmake [message #1769650 is a reply to message #1769642] Wed, 02 August 2017 12:13 Go to previous messageGo to next message
Kirill Dorofeev is currently offline Kirill DorofeevFriend
Messages: 26
Registered: February 2016
Junior Member
Hi,

your next step is to get sphinx.. If you're on debian/ubuntu then run apt-get install python-sphinx

br
Re: error at building Open62541 with Cmake [message #1769651 is a reply to message #1769650] Wed, 02 August 2017 12:15 Go to previous messageGo to next message
Kirill Dorofeev is currently offline Kirill DorofeevFriend
Messages: 26
Registered: February 2016
Junior Member
oh, sorry, haven't checked the screenshots.. on windows you might need to install pip and then run 'pip install sphinx'
Re: error at building Open62541 with Cmake [message #1769660 is a reply to message #1769651] Wed, 02 August 2017 13:23 Go to previous messageGo to next message
Stefan Profanter is currently offline Stefan ProfanterFriend
Messages: 11
Registered: July 2017
Junior Member
Since it says "Configuration done" everything is fine.
spinx is not really necessary.

You can also just run make now (or use your specific compiler tool) and it should work.

More details on how to compile everything can also be found here:
https://eclipse.org/4diac/en_help.php -> Using Communication Protocols -> OPC UA
Re: error at building Open62541 with Cmake [message #1769669 is a reply to message #1769660] Wed, 02 August 2017 14:03 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 454
Registered: January 2014
Senior Member
Dear Fei,
could you be so kind and post such issues also directly at the open62541 forums. It think this is definitely helpful for other open62541 users.
Previous Topic:OPC UA Client
Next Topic:Duplicate/Copy 4diac applications
Goto Forum:
  


Current Time: Mon Feb 19 20:45:45 GMT 2018

Powered by FUDForum. Page generated in 0.02330 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software