Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Newly created RCP application: 81 errors :-((Created a new RCP example application - does not build/compile)
Newly created RCP application: 81 errors :-( [message #1769554] Tue, 01 August 2017 14:38 Go to next message
Michael Moser is currently offline Michael MoserFriend
Messages: 33
Registered: October 2012
Location: Z├╝rich, Switzerland
Member
I wanted to educate myself on Eclipse RCP applications and how to create products and features. So, I downloaded and installed the RCP and RAP edition of the latest Eclipse version (Oxygen). I then started the "Tutorial: Create a Rich Client Application", i.e. I started to follow its cheat sheet.

First step is to create an example RCP plugin project "com.example.rcpapp".
I did so exactly as described which yielded a project with 80+ errors (mostly plugins, packages and types that can't be resolved) - see attached screen shot

That means that already the second step (starting the produced example application) is impossible!

NOT exactly very impressive and convincing. :-(

Aren't these cheat sheets and the steps they describe automatically tested during the build/release of a new eclipse release train?

Later edit: I meanwhile deleted and re-downloaded and re-installed the RCP&RAP edition (using the Oomph installer). Using that new virgin install the creation of the example project went fine. I am not aware of having done anything different before, but this time things are working as expected. Odd! But sorry for the bandwidth consumed...

[Updated on: Tue, 01 August 2017 15:41]

Report message to a moderator

Re: Newly created RCP application: 81 errors :-( [message #1770143 is a reply to message #1769554] Tue, 08 August 2017 15:15 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 788
Registered: January 2012
Senior Member

Hmm, I tried and they worked for me, though the "Hello RCP" example doesn't show.

Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:equinox launcher VS ini file
Next Topic:Product created from a working plugin fails to start
Goto Forum:
  


Current Time: Thu Nov 15 17:25:41 GMT 2018

Powered by FUDForum. Page generated in 0.02060 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top