Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » Can't change default sysml Block preferences
Can't change default sysml Block preferences [message #1769015] Tue, 25 July 2017 16:42 Go to next message
Justin Berrier is currently offline Justin BerrierFriend
Messages: 4
Registered: July 2017
Junior Member
I'm trying to change the default preferences for sysml blocks (and others nodes) by using the preferences window but can't find such an option. My version of eclipse is Neon.3 Release (4.6.3), my version of papyrus is 2.0.3.201703080851, and I have the sysml 1.1 and 1.4 versions installed. Attached is an image of where I expect to see such preferences. Note, I know they exist because the sysml youtube tutorial at the 1:50 time mark (youtube.com/watch?v=jj0e3fHQK7Q) shows them. Pls help.
  • Attachment: Capture.PNG
    (Size: 18.95KB, Downloaded 44 times)
Re: Can't change default sysml Block preferences [message #1769072 is a reply to message #1769015] Wed, 26 July 2017 09:26 Go to previous messageGo to next message
Remi Schnekenburger is currently offline Remi SchnekenburgerFriend
Messages: 167
Registered: July 2009
Location: Palaiseau, France
Senior Member
Hi Justin,

The support of preferences has been replaced in the last versions by CSS and other configuration support, that are easier to share with others. I invite you to read the following wiki page in order to understand this support and find the options you want to get.

Link to the wiki page: https://wiki.eclipse.org/MDT/Papyrus/UserGuide/CSS

Cheers,
Rémi


Remi Schnekenburger

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Can't change default sysml Block preferences [message #1769203 is a reply to message #1769072] Thu, 27 July 2017 15:23 Go to previous message
Justin Berrier is currently offline Justin BerrierFriend
Messages: 4
Registered: July 2017
Junior Member
Thx for the info Rémi. I have tried using the below code to hide the attributes compartment on blocks, but it doesn't seeem to work.

Compartment[kind="attributes"]{
visible:false;
}

Just a side note, this css scripting business takes too much effort. It would be nice if the feature shown in the image below still existed in the program. Why is it was taking out is beyond me.

index.php/fa/30156/0/
  • Attachment: Capture.PNG
    (Size: 487.43KB, Downloaded 120 times)
Previous Topic:Problem opening profile models created in previous version of Papyrus
Next Topic:Multiple schema generation with different namespaces
Goto Forum:
  


Current Time: Sat Oct 20 12:48:34 GMT 2018

Powered by FUDForum. Page generated in 0.01650 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top