Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Kura » MQTT and demo heater(Error connectingorg.eclipse.kura.web.shared.GwtKuraException)
MQTT and demo heater [message #1768690] Fri, 21 July 2017 15:44 Go to next message
Maury Tumbajoy is currently offline Maury TumbajoyFriend
Messages: 4
Registered: May 2017
Junior Member
Hi,

I'm trying to use iot.eclipse.org port 1883 to publish messages to the cloud. I installed the demo heater bundle on my raspberry pi and set the broker-url to mqtt://iot.eclipse.org:1883 and the connect.auto-on-startup* to true.

I saw that my status did not change. I have tried the url mqtts://iot.eclipse.org:8883 too but the error is the same. I displayed the Kura log and said that DataPublisherService not connected.

What must I do? Thanks.



  • Attachment: Cloud_Kura.jpg
    (Size: 85.92KB, Downloaded 44 times)
  • Attachment: Error.jpg
    (Size: 973.19KB, Downloaded 50 times)
Re: MQTT and demo heater [message #1768890 is a reply to message #1768690] Mon, 24 July 2017 15:48 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 260
Registered: July 2015
Location: Italy
Senior Member
Hi,
could you please share the entire configuration you used?
Did you try to connect at a different time? Because it can happen that the connection does not succeed due to the high load of the Eclipse broker.

Best regards,
Matteo
Re: MQTT and demo heater [message #1768914 is a reply to message #1768890] Mon, 24 July 2017 22:43 Go to previous messageGo to next message
David Woodard is currently offline David WoodardFriend
Messages: 420
Registered: July 2014
Senior Member
Hello,

The question is also being tracked here [1].

[1] https://stackoverflow.com/questions/45246202/error-to-connect-mqttdata-transport-to-eclipse-broker

Thanks,
--Dave
Re: MQTT and demo heater [message #1768974 is a reply to message #1768914] Tue, 25 July 2017 10:29 Go to previous messageGo to next message
Maury Tumbajoy is currently offline Maury TumbajoyFriend
Messages: 4
Registered: May 2017
Junior Member
Hi Mateo,

Thanks for your response.

I installed the heater bundle to Kura 3.0.0 in my raspberry pi B (with raspbian) and configured the MQTT client in the MqttDataTransport (broker url) and the DataService (connect.auto-on-startup). I guess I have internet access because I am able to ping to google.com but I don't really know.

Regards,
Maury Vanessa T.

[Updated on: Tue, 25 July 2017 11:48]

Report message to a moderator

Re: MQTT and demo heater [message #1768976 is a reply to message #1768974] Tue, 25 July 2017 10:35 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 260
Registered: July 2015
Location: Italy
Senior Member
Hi,
it seems that the framework is not able to reach Internet.
As you can see from the log, the gateway is not able to sync the clock.
Which is your network configuration?

Best regards,
Matteo
Re: MQTT and demo heater [message #1768994 is a reply to message #1768976] Tue, 25 July 2017 13:58 Go to previous messageGo to next message
Maury Tumbajoy is currently offline Maury TumbajoyFriend
Messages: 4
Registered: May 2017
Junior Member
Hi Matteo,

The raspberry pi network configuration is:

eth0 Link encap:Ethernet HWaddr b8:27:eb:bb:54:7c
inet addr:10.3.1.153 Bcast:10.3.255.255 Mask:255.255.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:270355 errors:0 dropped:0 overruns:0 frame:0
TX packets:31884 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:28964604 (27.6 MiB) TX bytes:5270383 (5.0 MiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:400 (400.0 B) TX bytes:400 (400.0 B)

And the kura's network configuration is:

eth0 10.3.1.153
subnet mask: 255.255.0.0
Mode: WAN
IP Acquisition: DHCP
Gateway 10.3.0.254

lo 127.0.0.1
subnet mask: 255.0.0.0
Mode: LAN

Regards,
Maury Vanessa T.
Re: MQTT and demo heater [message #1768998 is a reply to message #1768994] Tue, 25 July 2017 14:05 Go to previous messageGo to next message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 260
Registered: July 2015
Location: Italy
Senior Member
Ok, so it seems correctly configured.
Are you in a residential network or a business one? Is it possible that you have a firewall that is blocking the mqtt ports?

Just to do a simple test. If, from the device, you do a
telnet iot.eclipse.org 1883
, what happens?
Re: MQTT and demo heater [message #1769011 is a reply to message #1768998] Tue, 25 July 2017 15:52 Go to previous messageGo to next message
Maury Tumbajoy is currently offline Maury TumbajoyFriend
Messages: 4
Registered: May 2017
Junior Member
Hi,

I am in a business network. Yes, probably I have a firewall blocking the mqtt port.

I did the test and got the following response:
Trying 198.41.30.241...
telnet: Unable to connect to remote host: Connection timed out

Thanks for your help.

[Updated on: Tue, 25 July 2017 16:10]

Report message to a moderator

Re: MQTT and demo heater [message #1769019 is a reply to message #1769011] Tue, 25 July 2017 17:36 Go to previous message
Matteo Maiero is currently offline Matteo MaieroFriend
Messages: 260
Registered: July 2015
Location: Italy
Senior Member
I believe it is the case, since you are having the same issue with telnet.
Previous Topic:Where the MQTT messages has been decoded using the google protobuf?
Next Topic:ConfigurableComponent is not getting activated
Goto Forum:
  


Current Time: Wed Sep 19 04:58:23 GMT 2018

Powered by FUDForum. Page generated in 0.02434 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top