Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Forte build failure on Mac with architecture target Mac
Forte build failure on Mac with architecture target Mac [message #1767950] Wed, 12 July 2017 10:33 Go to next message
Jan Makowski is currently offline Jan MakowskiFriend
Messages: 1
Registered: July 2017
Junior Member
Hello,

my build on Mac (FORTE_ARCHITECTURE=Mac, no further custom settings) fails with:
/usr/local/Cellar/cmake/3.8.2/bin/cmake -E cmake_link_script CMakeFiles/forte_stringlist_externals.dir/link.txt --verbose=1
/usr/bin/ar qc libforte_stringlist_externals.a  
ar: no archive members specified
usage:  ar -d [-TLsv] archive file ...

It seems that Mac's ar unlike Linux ar always requires an object-file.

I looked at the build system, but I couldn't figure out at which point it fails. Could you please point me to the right direction? Which file(s) is/are not compiled in the Mac version?
Re: Forte build failure on Mac with architecture target Mac [message #1768111 is a reply to message #1767950] Thu, 13 July 2017 16:03 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 523
Registered: January 2014
Senior Member
As I commented on the bug [1] a workaround for this issue is to deactivate the CMake option FORTE_LINKED_STRINGDICT.

[1]https://bugs.eclipse.org/bugs/show_bug.cgi?id=519632
Previous Topic:MODBUS Client FB dont write Coil registers and create one connection by Block
Next Topic:Polysun 4diac plugin controller
Goto Forum:
  


Current Time: Tue May 22 21:53:01 GMT 2018

Powered by FUDForum. Page generated in 0.02524 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top