Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Arduino C++ Tools - ESP8266mDNS library( Error compiling with ESP8266mDNS)
Arduino C++ Tools - ESP8266mDNS library [message #1767946] Wed, 12 July 2017 10:10 Go to next message
lynne nux is currently offline lynne nuxFriend
Messages: 1
Registered: June 2017
Junior Member
Using Eclipse Neon.3, Linux Mint 18, Arduino C++ Tools 9.2.1.201704050430

Most projects work with few problems. Great work Doug, thank you.

In essence, when I started a new project (no code at all beyond starter template) and included just the ESP8266mDNS and ESP8266WiFi libs the build errored:

/home/rob/.arduinocdt/packages/esp8266/hardware/esp8266/2.3.0/libraries/ESP8266mDNS/ESP8266mDNS.cpp: In member function 'void MDNSResponder::enableArduino(uint16_t, bool)':
<command-line>:0:15: error: 'ESP8266_WEMOS_D1MINI' was not declared in this scope
ESP8266mDNS.cpp:841:44: note: in expansion of macro 'ARDUINO_BOARD'
addServiceTxt("arduino", "tcp", "board", ARDUINO_BOARD);


I fixed it manually: the build line included:
... xtensa-lx106-elf-g++ ... -DARDUINO_BOARD="ESP8266_WEMOS_D1MINI" ...
I changed it to:
... xtensa-lx106-elf-g++ ... -DARDUINO_BOARD=\"ESP8266_WEMOS_D1MINI\" ... (note extra backslashes in front of quotes)

I'm guessing platform.txt needs an extra 2 backslashes before quotes in the appropriate places? I haven't changed it as it has worked fine until ESP8266mDNS and I know nothing of Arduino infrastructure.
NOTE: the ESP8266mDNS library was a nuisance - it didn't download with a library.properties file and didn't show up in the library list until I fudged one.

Other, non-important, observations:
Arduino Downloads Manager : Seems to give lots of "Unhandled event loop exception" from cdt. Mainly works OK though I think.
Flashing failed until I made myself a member of dialout group.
Normal CDT stuff like Indexing, refactoring etc. work brilliantly. Very big thanks again Doug. (Great for an Arduino newbie like me.)
Ability to exclude files from build is not implemented it seems?
I assume the only way of getting rid of the admittedly very friendly Arduino toolbar is a separate install of Eclipse?
Re: Arduino C++ Tools - ESP8266mDNS library [message #1792982 is a reply to message #1767946] Thu, 26 July 2018 22:37 Go to previous messageGo to next message
Michael Asman is currently offline Michael AsmanFriend
Messages: 1
Registered: July 2018
Junior Member
I'm using Eclipse Photo Release 4.8.0 with Eclipse C++ IDE for Arduino 9.5.0.201806170908. I am extremely new to Eclipse and just playing with Arduino boards for fun.
I managed to fix the other issue you mentioned regarding the library.properties file. I cannot find the line that you mention fixing about. I'm about to give up and go back to the Arduino IDE--please give some further info for fixing this issue. Also, am I correct that both of these issues should be reported to the maintainer of the ESP8266mDNS libarary for a long term fix?

Thanks,
Michael
Re: Arduino C++ Tools - ESP8266mDNS library [message #1793345 is a reply to message #1767946] Mon, 06 August 2018 04:50 Go to previous message
Nicolas Acosta Huenulef is currently offline Nicolas Acosta HuenulefFriend
Messages: 1
Registered: August 2018
Junior Member
Guys, you got to create a librariy.properties file on

.arduinocdt\packages\esp8266\hardware\esp8266\*YOUR VERSION HERE*\libraries\ESP8266mDNS

With the following contents
name=ESP8266mDNS	
version=1.0
author=ESP
maintainer=ESP
sentence=mDNS
paragraph=mDNS
category=Communication
url=
architectures=esp8266

Only then you can add the library on your project and proceed.
Looks like they forgot to add them (?)
Previous Topic:Config option in debug configuration
Next Topic: "make" is not found in PATH hello
Goto Forum:
  


Current Time: Mon Nov 19 20:02:06 GMT 2018

Powered by FUDForum. Page generated in 0.02315 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top