Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Ordering of dynamic working sets
Ordering of dynamic working sets [message #1767203] Mon, 03 July 2017 14:26 Go to next message
Christian Pontesegger is currently offline Christian PonteseggerFriend
Messages: 197
Registered: July 2009
Location: Graz, Austria
Senior Member
Using dynamic working sets helps to setup a fresh workspace. But what drives me nuts about it is the ordering of these working sets that gets screwed up on any project import.

Is there a way to stop Working sets from gettting reordered in the Package Explorer?

thanks
Christian
Re: Ordering of dynamic working sets [message #1767434 is a reply to message #1767203] Thu, 06 July 2017 04:38 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29549
Registered: July 2009
Senior Member
I've not noticed this problem. Is the order initially the way you want it? Does that match the order you defined in the setup model? In the view menu's Configure Working Sets... is "Sort working sets" unchecked?
Re: Ordering of dynamic working sets [message #1767697 is a reply to message #1767434] Mon, 10 July 2017 06:19 Go to previous messageGo to next message
Christian Pontesegger is currently offline Christian PonteseggerFriend
Messages: 197
Registered: July 2009
Location: Graz, Austria
Senior Member
Sorting is deactivated. When my Oomph profile defines 3 working sets, ordered A, B, C I do see them in reversed order when the working sets are created on my local installation., so I end up with C, B, A. Then I typically sort them manually according to my needs.
Whenver I then do an import from an existing workspace or a import from a git repo sorting gets reverted to C, B, A.

Besides the dynamic working sets I also have some statically defined ones. Possibly there is a problem when these things get mixed?
Re: Ordering of dynamic working sets [message #1768030 is a reply to message #1767697] Thu, 13 July 2017 06:40 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29549
Registered: July 2009
Senior Member
I do generally expect to see them show up in the order in which they appear in the setup model, but of course we need to apply those to what's in the underlying workbench representation, and if that has other things , I'm not exactly sure what happens. If there is some relatively straight forward way to reproduce a problem, please describe it in a bugzilla.
Previous Topic:Escape ${} in "Resource Creation"
Next Topic:Unable to install Eclipse on MAC
Goto Forum:
  


Current Time: Mon Sep 24 15:10:46 GMT 2018

Powered by FUDForum. Page generated in 0.02303 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top