Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » gradle builder xtextbin file
gradle builder xtextbin file [message #1766099] Thu, 15 June 2017 16:31 Go to next message
anil chalil is currently offline anil chalilFriend
Messages: 38
Registered: October 2010
Member
Hi,

I created a build.gradle file for my language with id 'org.xtext.builder' version '1.0.18' but when i run gradle build from command line gradle build is failing with lots of errors like :
Caused by: org.eclipse.emf.ecore.resource.impl.ResourceSetImpl$1DiagnosticWrappedException: java.io.FileNotFoundException: JAR entry henkan/dsl/HDsl.xtextbin not found in /home/capacman/.m2/repository/henkan/dsl/henkan.dsl/1.0.0-SNAPSHOT/henkan.dsl-1.0.0-SNAPSHOT.jar
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.handleDemandLoadException(ResourceSetImpl.java:319)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:278)
at org.eclipse.xtext.resource.XtextResourceSet.getResource(XtextResourceSet.java:265)
at org.eclipse.xtext.resource.SynchronizedXtextResourceSet.getResource(SynchronizedXtextResourceSet.java:25)
at org.eclipse.xtext.parser.BaseEPackageAccess.loadResource(BaseEPackageAccess.java:52)
... 143 more
Caused by: java.io.FileNotFoundException: JAR entry henkan/dsl/HDsl.xtextbin not found in /home/capacman/.m2/repository/henkan/dsl/henkan.dsl/1.0.0-SNAPSHOT/henkan.dsl-1.0.0-SNAPSHOT.jar
at sun.net.www.protocol.jar.JarURLConnection.connect(JarURLConnection.java:142)
at sun.net.www.protocol.jar.JarURLConnection.getInputStream(JarURLConnection.java:150)
at org.eclipse.emf.ecore.resource.impl.URIHandlerImpl.createInputStream(URIHandlerImpl.java:207)
at org.eclipse.emf.ecore.resource.impl.ExtensibleURIConverterImpl.createInputStream(ExtensibleURIConverterImpl.java:360)
at org.eclipse.xtext.resource.XtextResourceSet$1.createInputStream(XtextResourceSet.java:298)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1269)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoad(ResourceSetImpl.java:259)
at org.eclipse.emf.ecore.resource.impl.ResourceSetImpl.demandLoadHelper(ResourceSetImpl.java:274)
... 146 more

I checked my jar file and there is an henkan/dsl/HDsl.xtextbin file actually.
Re: gradle builder xtextbin file [message #1766118 is a reply to message #1766099] Fri, 16 June 2017 06:07 Go to previous messageGo to next message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 639
Registered: July 2009
Location: Dortmund, Germany
Senior Member

Set up a new Xtext project with Gradle support, try to build it. Is this the same error? If yes, attach that sample project. Which Xtext version? If no, compare the two projects.
Re: gradle builder xtextbin file [message #1779897 is a reply to message #1766099] Mon, 15 January 2018 14:17 Go to previous message
Martin Trummer is currently offline Martin TrummerFriend
Messages: 17
Registered: December 2017
Junior Member
I had the same problem.
Not sure what the cause was. But stopping all gradle daemons and then starting the build worked for me.
Previous Topic:Cancel validator when too much errors are present
Next Topic:Organize Imports not working in my xbase dsl
Goto Forum:
  


Current Time: Tue Nov 13 00:07:51 GMT 2018

Powered by FUDForum. Page generated in 0.01553 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top