Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Can't install eclipse with installer - (Eclipse IDE for Java Developers install failure)
Can't install eclipse with installer - [message #1765402] Fri, 09 June 2017 08:41 Go to next message
Dirk van Oosterhout is currently offline Dirk van OosterhoutFriend
Messages: 1
Registered: June 2017
Junior Member
I had Eclipse installed before, but now it won't install anymore
I tried installing Eclipse IDE for Java Developers
I tried multiple times but it kept giving the same feedback

Installation Log:

[2017-06-09 10:36:43] Executing bootstrap tasks
[2017-06-09 10:36:43] Java(TM) SE Runtime Environment 1.8.0_131-b11
[2017-06-09 10:36:43] Product org.eclipse.products.epp.package.java.neon
[2017-06-09 10:36:43] Bundle org.eclipse.oomph.setup 1.7.0.v20170224-1311, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
[2017-06-09 10:36:43] Bundle org.eclipse.oomph.setup.core 1.7.0.v20170301-0747, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
[2017-06-09 10:36:43] Bundle org.eclipse.oomph.setup.p2 1.7.0.v20170217-1051, build=2932, branch=cc66c993507ade50e4b3a824a3adb4e94c4ac25f
[2017-06-09 10:36:44] Performing P2 Director (Eclipse IDE for Java Developers (Neon))
[2017-06-09 10:36:44] Offline = false
[2017-06-09 10:36:44] Mirrors = true
[2017-06-09 10:36:44] Resolving 23 requirements from 3 repositories to D:\Programs\Eclipse Neon\eclipse
[2017-06-09 10:36:44] Requirement epp.package.java [4.6.0,4.7.0)
[2017-06-09 10:36:44] Requirement org.eclipse.platform.feature.group [4.6.0,4.7.0)
[2017-06-09 10:36:44] Requirement org.eclipse.rcp.feature.group [4.6.0,4.7.0)
[2017-06-09 10:36:44] Requirement org.eclipse.buildship.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.egit.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.egit.mylyn.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.jdt.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.jgit.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.m2e.feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.m2e.logback.feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn.context_feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn.git.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn.hudson.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn.ide_feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn.java_feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn.wikitext_feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.mylyn_feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.recommenders.mylyn.rcp.feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.recommenders.rcp.feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.recommenders.snipmatch.rcp.feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.wst.xml_ui.feature.feature.group
[2017-06-09 10:36:44] Requirement org.eclipse.oomph.setup.feature.group
[2017-06-09 10:36:44] Repository http://download.eclipse.org/technology/epp/packages/neon
[2017-06-09 10:36:44] Repository http://download.eclipse.org/releases/neon
[2017-06-09 10:36:44] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2017-06-09 10:36:44] ERROR: org.eclipse.equinox.p2.metadata.repository code=1002 Unable to read repository at http://download.eclipse.org/releases/neon.
ERROR: org.eclipse.equinox.p2.repository code=0 An error occurred while downloading http://download.eclipse.org/technology/epp/packages/neon/content.xml.xz. The cache file C:\Users\Dirk\.p2\org.eclipse.equinox.p2.repository\cache\downloading\2079680757 could not be renamed to C:\Users\Dirk\.p2\org.eclipse.equinox.p2.repository\cache\2079680757.
at org.eclipse.equinox.internal.p2.repository.CacheManager.updateCache(CacheManager.java:428)
at org.eclipse.equinox.internal.p2.repository.CacheManager.createCacheFromFile(CacheManager.java:132)
at org.eclipse.equinox.internal.p2.metadata.repository.XZedSimpleMetadataRepositoryFactory.getLocalFile(XZedSimpleMetadataRepositoryFactory.java:56)
at org.eclipse.equinox.internal.p2.metadata.repository.XZedSimpleMetadataRepositoryFactory.load(XZedSimpleMetadataRepositoryFactory.java:78)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(MetadataRepositoryManager.java:57)
at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:768)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:117)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:396)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:199)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:463)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:96)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)
at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository.addChild(CompositeMetadataRepository.java:166)
at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepository.<init>(CompositeMetadataRepository.java:106)
at org.eclipse.equinox.internal.p2.metadata.repository.CompositeMetadataRepositoryFactory.load(CompositeMetadataRepositoryFactory.java:122)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.factoryLoad(MetadataRepositoryManager.java:57)
at org.eclipse.equinox.internal.p2.repository.helpers.AbstractRepositoryManager.loadRepository(AbstractRepositoryManager.java:768)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.oomph.util.ReflectUtil.invokeMethod(ReflectUtil.java:117)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:396)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager.loadRepository(CachingRepositoryManager.java:199)
at org.eclipse.oomph.p2.internal.core.CachingRepositoryManager$Metadata.loadRepository(CachingRepositoryManager.java:463)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:96)
at org.eclipse.equinox.internal.p2.metadata.repository.MetadataRepositoryManager.loadRepository(MetadataRepositoryManager.java:92)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$RepositoryLoader$Worker.perform(ProfileTransactionImpl.java:1613)
at org.eclipse.oomph.util.WorkerPool$Worker.run(WorkerPool.java:428)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

[2017-06-09 10:36:44]
Re: Can't install eclipse with installer - [message #1765449 is a reply to message #1765402] Fri, 09 June 2017 15:30 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29655
Registered: July 2009
Senior Member
Likely a virus scanner involved, locking the file as soon as it's been created, blocking the rename/move attempt... In https://www.eclipse.org/forums/index.php/mv/msg/1086672/1765355/#msg_1765355 that was the conclusion.
Re: Can't install eclipse with installer - [message #1790723 is a reply to message #1765402] Fri, 15 June 2018 02:59 Go to previous message
Vikram Sherigar is currently offline Vikram SherigarFriend
Messages: 1
Registered: June 2018
Junior Member
I had faced a similar error while installing Eclipse Oxygen 3a on my Windows 10 system
Quote:
ERROR: org.eclipse.equinox.p2.repository code=0

and the reason was quite silly!

The directory where eclipse was getting installed Quote:
c:\Users\<myusername>\
was open.

I just deleted the Quote:
eclipse
directory, closed Windows Explorer window and reinitiated the installer. It worked!
Previous Topic:Installation error. Can't download findbugs plugin.
Next Topic:Setup Task Development
Goto Forum:
  


Current Time: Tue Nov 20 14:27:02 GMT 2018

Powered by FUDForum. Page generated in 0.02237 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top