Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » org.xtext.xtend gradle plugin. (Error while running headless build to generate Xtext language jar)
org.xtext.xtend gradle plugin. [message #1764878] Fri, 02 June 2017 19:46 Go to next message
Deniss Artisskis is currently offline Deniss ArtisskisFriend
Messages: 5
Registered: June 2017
Junior Member
Good day Everybody. I am new to gradle plugins and gradle in general. However I was given an assignment to create build.gradle file to generate the DSL jar file ftom Xtex/Xtend DSL project. I am taking it step by step. I am able to run mwe2 Workflow to generate language infrastructure. However when I try to use org.xtext.xtend gradle plugin (generateXtext task) I get the following error:
:generateXtext FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':generateXtext'.
> Could not resolve all dependencies for configuration ':detachedConfiguration2'.
> Could not find org.eclipse.xtend:org.eclipse.xtend.core:0752.
Searched in the following locations:
repo1.maven.org/maven2/org/eclipse/xtend/org.eclipse.xtend.core/0752/org.eclipse.xtend.core-0752.pom
repo1.maven.org/maven2/org/eclipse/xtend/org.eclipse.xtend.core/0752/org.eclipse.xtend.core-0752.jar
center.bintray.com/org/eclipse/xtend/org.eclipse.xtend.core/0752/org.eclipse.xtend.core-0752.pom
jcenter.bintray.com/org/eclipse/xtend/org.eclipse.xtend.core/0752/org.eclipse.xtend.core-0752.jar
Required by:
project :

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

However I do not refer anywhere to ecore - 0752. in fact I am not sure where did it come from???

Xtext version 2.12.0
gradle version 3.5.0

Interestingly enough when I used Xtext version 2.10.0 I did not get this dependency error but instead I had an issue with compiling Xtend sources because they references Java classes from different packages of the same project (compiling in eclipdse has no issue - issue was only when running grade from command line) . Then I found that this was an issue in Xtext itself and I needed to upgrade and I upgraded to the latest version. After upgrade and switching dependencies to appropriate Xtext 2.12.0 jars I started to get that strange dependency error above. As I said already above I have no idea where org.eclipse.xtend.core-0752.jar comes into picture, besides it is non existant. I have latest version of the same jar. Any clue?

Thanks a lot,
Deniss

[Updated on: Mon, 05 June 2017 11:45]

Report message to a moderator

Re: org.xtext.xtend gradle plugin. [message #1764986 is a reply to message #1764878] Mon, 05 June 2017 14:39 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32022
Registered: July 2009
Senior Member
You'll get much better help on Xtext's TMF forum.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: org.xtext.xtend gradle plugin. [message #1764996 is a reply to message #1764986] Mon, 05 June 2017 15:53 Go to previous messageGo to next message
Deniss Artisskis is currently offline Deniss ArtisskisFriend
Messages: 5
Registered: June 2017
Junior Member
Yes I asked moderator to move it there, or do I have to post a new message there?
Re: org.xtext.xtend gradle plugin. [message #1764999 is a reply to message #1764996] Mon, 05 June 2017 16:09 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14067
Registered: July 2009
Senior Member
You are at Xtext forum already

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: org.xtext.xtend gradle plugin. [message #1765014 is a reply to message #1764999] Mon, 05 June 2017 17:14 Go to previous messageGo to next message
Deniss Artisskis is currently offline Deniss ArtisskisFriend
Messages: 5
Registered: June 2017
Junior Member
Thanks Christian,
Have you seen anything like this? I am stuck.

Deniss
Re: org.xtext.xtend gradle plugin. [message #1765017 is a reply to message #1765014] Mon, 05 June 2017 17:25 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14067
Registered: July 2009
Senior Member
See you other post

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: org.xtext.xtend gradle plugin. [message #1765019 is a reply to message #1765017] Mon, 05 June 2017 17:42 Go to previous message
Deniss Artisskis is currently offline Deniss ArtisskisFriend
Messages: 5
Registered: June 2017
Junior Member
Oh I thought the other one Moderator did not let in
Previous Topic:Content Sensitive Autocomplete
Next Topic:Xtext gradle plugin error
Goto Forum:
  


Current Time: Fri Sep 24 13:20:41 GMT 2021

Powered by FUDForum. Page generated in 0.02196 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top