Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » Java application SWT components repaint to black
Java application SWT components repaint to black [message #1764465] Tue, 30 May 2017 09:11
Roger Bremon is currently offline Roger BremonFriend
Messages: 1
Registered: May 2017
Junior Member
We have a client java application that uses SWT (3.4.2) as the main graphic layer. In some cases, usually after extensive use, the application repaints the SWT widgets to black, keeping them in black, sometimes the application blocks, and finally forcing users to restart the application to solve the problem. Occasionally the same behaviour happens without user interaction.

The problem is only visible in Windows 8.1 tablets connected to a monitor display through a port replicator. In desktop computers with W7 we haven't been able to reproduce the casuistic.

Any ideas? Thanks!

[EDIT] Adding capture of the issue
https://s11.postimg.org/q4jk4k0ar/issue.png

[UPDATE] We have reproduced it with Windows 8.1. WITHOUT the port replicator.
  • Attachment: issue.PNG
    (Size: 26.48KB, Downloaded 33 times)

[Updated on: Wed, 07 June 2017 07:14]

Report message to a moderator

Previous Topic:Restricting the size of SWT-AWT bridge frame to parent composite
Next Topic:Eclipse RCP+ Standalone Application View not work on perspective change
Goto Forum:
  


Current Time: Fri Dec 15 23:43:30 GMT 2017

Powered by FUDForum. Page generated in 0.01506 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software