Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Flaky web access to git repository
Flaky web access to git repository [message #1764346] Sun, 28 May 2017 20:49 Go to next message
Henri Boucher is currently offline Henri BoucherFriend
Messages: 40
Registered: September 2015
Member
Left click on org.eclipse.efxclipse.git in git.eclipse.org/c returns the index with url:

http://git.eclipse.org/c/%0a%20SomeCustomInjectedHeader:injected_by_wvs/org.eclipse.cdt.old.git/diff/old2/cdt-home/developer/featurespec/2.0/contentassist.html/bpmn2-modeler/org.eclipse.bpmn2-modeler.git/cbi/org.eclipse.cbi.maven.plugins.git/babel/server.git/aether/aether-demo.git/aether/aether-update-site.git/acceleo/org.eclipse.acceleo.git/actf/org.eclipse.actf.visualization.git/chemclipse/org.eclipse.chemclipse.baselinedetec.git/amalgam/org.eclipse.amalgam.git/cdo/cdo.infrastructure.git/amp/org.eclipse.amp.git/cdo/cdo.git/bpmnmodeler/.git/amp/org.eclipse.amp.git/edt/org.eclipse.edt.git/camf/org.eclipse.camf.git/chemclipse/org.eclipse.chemclipse.filterdenoising.git/efxclipse/org.eclipse.efxclipse.git/

Also seaching for org.eclipse.efxclipse returns "No repositories found" with url:

http://git.eclipse.org/c/%20SomeCustomInjectedHeader:injected_by_wvs/org.eclipse.cdt.old.git/diff/old2/cdt-home/developer/featurespec/2.0/contentassist.html/bpmn2-modeler/org.eclipse.bpmn2-modeler.git/cbi/org.eclipse.cbi.maven.plugins.git/babel/server.git/aether/aether-demo.git/aether/aether-update-site.git/acceleo/org.eclipse.acceleo.git/actf/org.eclipse.actf.visualization.git/chemclipse/org.eclipse.chemclipse.baselinedetec.git/amalgam/org.eclipse.amalgam.git/cdo/cdo.infrastructure.git/amp/org.eclipse.amp.git/cdo/cdo.git/bpmnmodeler/.git/amp/org.eclipse.amp.git/edt/org.eclipse.edt.git/camf/org.eclipse.camf.git/chemclipse/org.eclipse.chemclipse.filterdenoising.git/?q=org.eclipse.efxclipse

I've had both work very rarely. I'm hoping this can be reproduced. The problem happens with repositories other than org.eclipse.efxclipse.git.
Re: Flaky web access to git repository [message #1764347 is a reply to message #1764346] Sun, 28 May 2017 21:48 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1026
Registered: July 2009
Senior Member
gitweb is not a part of EGit or JGit.

If you want to report this issue to webmaster file a bug in Bugzilla for project "Eclipse Foundation > Community", component "Git"

You may try the new gitiles browser which is available for repositories using Gerrit.
E.g. here is the master branch of the efxclipse repository:
https://git.eclipse.org/r/plugins/gitiles/efxclipse/org.eclipse.efxclipse/+/refs/heads/master
watch out for links named "browse" in the Gerrit Web UI, e.g. here
https://git.eclipse.org/r/#/admin/projects/efxclipse/org.eclipse.efxclipse,branches
or
https://git.eclipse.org/r/#/c/78133/1/bundles/runtime/org.eclipse.fx.core.di.context/src/org/eclipse/fx/core/di/context/internal/FXMLLoaderTypeProvider.java
Re: Flaky web access to git repository [message #1764348 is a reply to message #1764347] Sun, 28 May 2017 21:49 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1026
Registered: July 2009
Senior Member
I meant cgit which the foundation is using, not gitweb
Re: Flaky web access to git repository [message #1764349 is a reply to message #1764347] Sun, 28 May 2017 22:18 Go to previous message
Henri Boucher is currently offline Henri BoucherFriend
Messages: 40
Registered: September 2015
Member
Thanks. https://bugs.eclipse.org/bugs/show_bug.cgi?id=517337
Previous Topic:EGit crash after update Eclipse Mars
Next Topic:Missing blob when doing a git diff with jgit
Goto Forum:
  


Current Time: Wed Jun 20 10:04:58 GMT 2018

Powered by FUDForum. Page generated in 0.01788 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top