Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot install Kotlin Plugin in Ubuntu 16.04(While trying to install Kotlin Plugin via marketplace I get an error )
Cannot install Kotlin Plugin in Ubuntu 16.04 [message #1763810] Sat, 20 May 2017 07:12 Go to next message
Sven Schroeder is currently offline Sven SchroederFriend
Messages: 4
Registered: May 2017
Junior Member
I am on Linux Ubuntu 16.04 and using Eclipse Neon2.

Yesterday I tried to install the plugin for Kotlin via:
Help - Eclipse Marketplace - Search - Kotlin Plugin for Eclipse 0.8.2.

which leads to the following error:

Cannot complete the install because one or more required items could not be found.
Software currently installed: Oomph Setup 1.7.0.v20170210-1347 (org.eclipse.oomph.setup.feature.group 1.7.0.v20170210-1347)
Missing requirement: Oomph Setup 1.7.0.v20170210-1347 (org.eclipse.oomph.setup.feature.group 1.7.0.v20170210-1347) requires 'org.eclipse.oomph.setup.core.feature.group [1.7.0.v20170201-1648]' but it could not be found


So I thought to update the Oomph Setup . But it seems that this isn't working either:

Insufficient access privileges to apply this update.

Even when I try to run Eclipse via Terminal as Superuser it doesn't solve the problem. It seems to me, that I have got some general problems concerning privileges because I am unable to get any of the suggested available updates.

Any suggestions?
Re: Cannot install Kotlin Plugin in Ubuntu 16.04 [message #1763824 is a reply to message #1763810] Sun, 21 May 2017 08:18 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Did you create the installation with the installer? Which account/permissions did you use when you did that? Where did you physically locate the installation? By default the installer uses a shared bundle pool and by default that's physically located in ~/.p2/pool so the folder used for that and the permissions associated with it are also relevant...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Cannot install Kotlin Plugin in Ubuntu 16.04 [message #1763828 is a reply to message #1763824] Sun, 21 May 2017 12:57 Go to previous messageGo to next message
Sven Schroeder is currently offline Sven SchroederFriend
Messages: 4
Registered: May 2017
Junior Member
Unfortunately I cannot remember whether I used the installer or not. Therefore I don't know about any permissions I used during installation.

But I do have a ~/.p2/pool folder which contains
artifacts.xml features plugins

To be more specific the permissions for theses files/ folders are:

-rw-rw-r-- 1 zwenn zwenn 127K Feb 17 15:45 artifacts.xml
drwxrwxr-x 3 zwenn zwenn 4,0K Feb 17 15:43 .eclipseextension
drwxrwxr-x 65 zwenn zwenn 4,0K Feb 17 15:45 features
drwxrwxr-x 13 zwenn zwenn 44K Feb 17 15:45 plugins

Any further suggestions?
Thanks for your help!

Re: Cannot install Kotlin Plugin in Ubuntu 16.04 [message #1763834 is a reply to message #1763828] Sun, 21 May 2017 15:17 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31900
Registered: July 2009
Senior Member
Is the folder of the installation itself owned by you with all the necessary permissions? You could quickly try to create a new installation with the installer. That would take only a minute or two if you used the installer previously, and hope that this new one works better...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Cannot install Kotlin Plugin in Ubuntu 16.04 [message #1763880 is a reply to message #1763834] Mon, 22 May 2017 13:58 Go to previous message
Sven Schroeder is currently offline Sven SchroederFriend
Messages: 4
Registered: May 2017
Junior Member
O.K, a clean install using the installer did actually solve the problem. Thanks a lot for that! Although I would have liked to find a way around that solution , without doing a new install of eclipse. At least I am on Neon3 instead of version 2 now.

Greetings
Sven

One more thing: After installing the newer version of eclipse what is the best way to remove the old installation on system? Using synaptic it is hard for me to find out what package belongs to the old version and which one has to stay.
Tanks again.

[Updated on: Mon, 22 May 2017 14:44]

Report message to a moderator

Previous Topic:Eclipse git not working
Next Topic:How do you change the theme?
Goto Forum:
  


Current Time: Tue Jun 15 20:35:25 GMT 2021

Powered by FUDForum. Page generated in 0.03471 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top