Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Eclipse Web Tools Platform Project (WTP) » Existing webapp project now lost editor associations
Existing webapp project now lost editor associations [message #1760776] Tue, 02 May 2017 20:26 Go to next message
David M. Karr is currently offline David M. KarrFriend
Messages: 559
Registered: July 2009
Senior Member
I've had a project in Eclipse for a while, which has been working fine.

It's a Gradle multimodule project, but that may be irrelevant.

One of the subprojects is a pure webapp with html and javascript, although I use Gradle to build a WAR file with the contents.

Over the last few months, I've been able to edit the javascript and html perfectly fine.

A few days ago, I had some sort of unrelated Eclipse corruption, and I had to reinstall Eclipse. I think most of those issues have been resolved, but when I tried to work on this project today, I noticed that the icons for the html and javascript files were different. The HTML files have a little "world" icon, and when I try to open it, it tries to open it in the internal web browser. I tried to open a javascript file, and it seemed to try to open it in an external editor.

I figure this might require going into the Project Facets. When I just looked at it, it had "Java (1.8)" and "jst.web (2.4)" checked, although in the box below it said "Implementation of project facet jst.web could not be found. Functionality will be limited." I have no idea whether this is a fatal problem or not.

I also tried checking "Static Web Module" and refreshing the project, but that made no difference.

I see nothing significant in the eclipse log.
Re: Existing webapp project now lost editor associations [message #1760781 is a reply to message #1760776] Tue, 02 May 2017 21:36 Go to previous message
David M. Karr is currently offline David M. KarrFriend
Messages: 559
Registered: July 2009
Senior Member
Never mind. After I reinstalled Eclipse, I forgot that I had to install several other "base" plugins from the Neon update site, like the HTML and Javascript editors.
Previous Topic:Jetty 9: JSP, Servlets and WebSockets together
Next Topic:Neon GF 4 Deployed Web Services empty
Goto Forum:
  


Current Time: Mon Jun 18 23:16:24 GMT 2018

Powered by FUDForum. Page generated in 0.01968 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top