Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [EMFStore]:( How do I configure EMFStore)
[EMFStore]: [message #1760394] Wed, 26 April 2017 15:15 Go to next message
Garcia de Mirasierra Perez is currently offline Garcia de Mirasierra PerezFriend
Messages: 15
Registered: August 2015
Junior Member
Hello Maximilian,

I do eclipse plugin that It use EMF,ECP and EMFStore (version 1.7 ). I do product eclipse. In this product I use default EMFStore server configuration.

I want to use EMFStore server, but I want use my configuration, I canĀ“t it.

I define my profile (MyEMFStoreProfile ). Inside server profile I put my es.propeties with a property emfstore.connection.xmlrpc.port= 8081. And put a parameter '-profile=MyEMFStoreProfile ' in eclipse.ini file. But always create default profile and not use my profile.

Do you can help me?

Much thanks in advance.
Re: [EMFStore]: [message #1760476 is a reply to message #1760394] Thu, 27 April 2017 15:30 Go to previous messageGo to next message
Edgar Mueller is currently offline Edgar MuellerFriend
Messages: 17
Registered: March 2016
Junior Member
Hi,
how did you create your profile? For testing purposes, perhaps the easiest way is to just use a fresh profile name (let's say 'test'), start & shutdown EMFStore once (which will create the profile directory together with some default initialization) and then copy & paste your es.properties to ~/.emfstore/server/profiles/test/conf.
Alternatively, and what's also recommended in a production-like setting, you may want to use the extension point org.eclipse.emf.emfstore.server.configurationResource to specify an es.properties file to be used.

Cheers,
Edgar
Re: [EMFStore]: [message #1760533 is a reply to message #1760476] Fri, 28 April 2017 07:20 Go to previous messageGo to next message
Garcia de Mirasierra Perez is currently offline Garcia de Mirasierra PerezFriend
Messages: 15
Registered: August 2015
Junior Member
Hello Maximilan,

When I use EMFStrore with 'Launch an Eclipse application' the operation is as expected . But when I use 'Eclipse product export wizard' and I use that new one eclipse, dont read the new Profile.

Many thanks in advance .

Amalia
Re: [EMFStore]: [message #1760553 is a reply to message #1760533] Fri, 28 April 2017 09:01 Go to previous messageGo to next message
Garcia de Mirasierra Perez is currently offline Garcia de Mirasierra PerezFriend
Messages: 15
Registered: August 2015
Junior Member
Hello Maximilian,


It works, forgive me!!!!.


My problem is that in es.properties I put new values but in ECPRepository Wizard always show old values.

Many thank in advances
Re: [EMFStore]: [message #1761030 is a reply to message #1760553] Fri, 05 May 2017 12:52 Go to previous message
Maximilian Koegel is currently offline Maximilian KoegelFriend
Messages: 3
Registered: January 2017
Junior Member
OK, good to know it works for you now!

Cheers,
Maximilian

--
Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Previous Topic:[EMF Forms] Writing JUnit Tests for EMF Forms Use Case
Next Topic:[EMFStore]:How do you configure LDAP properties
Goto Forum:
  


Current Time: Mon Sep 25 13:25:59 GMT 2017

Powered by FUDForum. Page generated in 0.04298 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software