Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Permissions problems in my workspace (self-caused, self-resolved)(Cautionary tale of mistakenly installing Eclipse as root)
Permissions problems in my workspace (self-caused, self-resolved) [message #1759768] Tue, 18 April 2017 02:39 Go to next message
Linus Sch is currently offline Linus SchFriend
Messages: 5
Registered: April 2017
Junior Member
Hi,

I've had a rocky install experience with the latest version of Eclipse (Neon.3) onto Linux Mint 17.2 Rafaela. The installer would fail to start with a file permissions error, which I first tried to counter by running the installer with sudo - bad idea! Even though I changed the installation folder to a subfolder of my own home, some files ended up in /root/ and therefore that install would only start when run with sudo.

I am reasonably sure I was able to clean up that mess. For the next try I did chmod 777 on the downloaded and unpacked installer files, so that I could start the installer without sudo. This installation now starts up fine, but it does report some file permissions errors in the terminal I start it from, and upon shutdown I get a dialog box with a file permission error related to saving the workspace.

Doing ls -l on the installation folder, which is in the default ~/eclipse/java-neon/eclipse/ location, reveals that some of these files are owned by me and some of them are owned by root. Here is the question: is that correct? Or should I just take ownership of the entire installation folder (which I'm 99% sure would get rid of the errors), is that what it should be like? Or, is it at least a safe workaround?

Given the large repositories of many Linux distros I don't have a lot of experience with installing things manually, which might be the problem here. I'm happy to learn Smile

[Updated on: Tue, 18 April 2017 09:08]

Report message to a moderator

Re: Permissions problems in my installation files (Linux) [message #1759820 is a reply to message #1759768] Tue, 18 April 2017 09:00 Go to previous message
Linus Sch is currently offline Linus SchFriend
Messages: 5
Registered: April 2017
Junior Member
UPDATE: I was wrong, but I found it, and I think I have fixed it.

Looking closer all the file permission errors were actually in my workspace/.metadata, not in the installation folder. This was of course caused by my earlier mistake of installing Eclipse as root, as I had pointed that install to the same default workspace, hence root got ownership of some of the files in there. I have reclaimed ownership of all of my workspace and the errors are gone. Solved? I think so!

For completeness: all of the files in the Eclipse installation folder are actually owned by me. No problems there.
Previous Topic:Eclipse Integration
Next Topic:Java import statement hints
Goto Forum:
  


Current Time: Sun Jun 20 20:14:33 GMT 2021

Powered by FUDForum. Page generated in 0.03127 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top