Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Indigo RCP/RAP unable to open Eclipse.app, but exe opens from cmd line(The Eclipse executable launcher was unable to locate its companion shared library.)
Indigo RCP/RAP unable to open Eclipse.app, but exe opens from cmd line [message #1758968] Tue, 04 April 2017 20:35
Zak Kinsey is currently offline Zak KinseyFriend
Messages: 1
Registered: April 2017
Junior Member
So in short I'm attempting to install Indigo for RCP and RAP developers.

After unzipping and attempting to launch the app I get the error: "The Eclipse executable launcher was unable to locate its
companion shared library."

However I can run both:
/Users/zak/targetstream/eclipse/Indigo/eclipse/eclipse ; exit;
and
/Users/zak/targetstream/eclipse/Indigo/eclipse/Eclipse.app/Contents/MacOS/eclipse ; exit;

with no issues.

I'm getting my download from: https://www.eclipse.org/downloads/packages/release/Indigo/SR2
and the checksum matches.

My system info is:
MacBook Pro (15-inch, 2016) macOS Sierra 10.12.4
2.9 GHz Intel Core i7
16 GB 2133 MHz LPDDR3
Radeon Pro 460 4096 MB
Intel HD Graphics 530 1536 MB

EDIT: (more info) echo $JAVA_HOME
/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home

Now for unzipping unzipping, I've used Mac's default unarchiver, KeKa, zmd line unzip, and the cmd tar xzf <eclipse.tar.gz file>. All of these produce the same cannot find library error.

I've scoured the internet with no luck. The following are but a few of the resources I've used to attempt to fix this.
EDIT: apparently since I have 0 posts I can't post any external links. SO in summation I've looked into the .ini file to make sure the libraries match up to what's on my system. They do.
https://www.eclipse.org/forums/index.php/t/350869/

All roads seem to lead to an unzipping issue, but I'm at a complete loss at what else to try. A coworker ran into the same issue on an identical MacBook Pro and unzipping using KeKa solved his issue.

Any help or suggestions would be very much appreciated to this incredibly frustrated, and now unproductive, fellow.

[Updated on: Tue, 04 April 2017 21:56]

Report message to a moderator

Previous Topic:Marketplace
Next Topic:CreateProcess error=2, Can not run program "python" on Ant
Goto Forum:
  


Current Time: Mon Jun 14 16:20:23 GMT 2021

Powered by FUDForum. Page generated in 0.03632 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top