Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » Marshaller not generating namespace definition(Marshaller not generating namespace definition)
Marshaller not generating namespace definition [message #1758722] Sat, 01 April 2017 00:54
Varuna Jain is currently offline Varuna JainFriend
Messages: 1
Registered: April 2017
Junior Member
We just migrated from Weblogic 12.1 to Weblogic 12.2 and Weblogic 12.2 comes with eclipselink 2.6.1 version. In some cases marshaller is not generating name space definition for the elements. Here's the sample schema and output:

There are four XSD files in single text file which is attached to the topic.

output is also attached.

There is no definition for ns2 even though it's being referred. As part of debugging I realized that it may be issue with following line:
((XMLLogin) xmlContext.getSession().getDatasourceLogin()).setEqualNamespaceResolvers(true);

in JAXBContext.java.

In 2.0 version shipped with weblogic above line was conditional but now it always sets to true and hence it does not write namespace definition.

Any suggestions will be helpful?

Thanks,
Varuna
  • Attachment: test.txt
    (Size: 3.56KB, Downloaded 35 times)
  • Attachment: output.txt
    (Size: 0.54KB, Downloaded 40 times)
Previous Topic:Support for LocalDateTime
Next Topic:Do we have commercial support for eclipselink?
Goto Forum:
  


Current Time: Thu Nov 23 15:09:00 GMT 2017

Powered by FUDForum. Page generated in 0.02125 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software