Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Papyrus for Real Time » Papyrus-rt 0.9 Getting_Started: cannot select protocol for port
Papyrus-rt 0.9 Getting_Started: cannot select protocol for port [message #1758399] Tue, 28 March 2017 12:19 Go to next message
Andre Bossert is currently offline Andre BossertFriend
Messages: 5
Registered: February 2016
Junior Member
I'm trying to getting started with:
https://wiki.eclipse.org/Papyrus-RT/User_Guide/Getting_Started
and fresh Papyrus-RT 0.9 release.

In Step "Add a port to Pinger and set its type" i cannot select the protocol, OK is not possible...
Re: Papyrus-rt 0.9 Getting_Started: cannot select protocol for port [message #1758404 is a reply to message #1758399] Tue, 28 March 2017 12:55 Go to previous messageGo to next message
Andre Bossert is currently offline Andre BossertFriend
Messages: 5
Registered: February 2016
Junior Member
I'm a new Papyrus-RT user and maybe missed some point... Just started again with new project and have the same issue, the <<Protocol>> is there but cannot selected it for the Port:
Re: Papyrus-rt 0.9 Getting_Started: cannot select protocol for port [message #1758488 is a reply to message #1758404] Wed, 29 March 2017 08:51 Go to previous messageGo to next message
Peter Cigehn is currently offline Peter CigehnFriend
Messages: 49
Registered: September 2014
Member
Hi,

Unfortunately the https://wiki.eclipse.org/Papyrus-RT/User_Guide/Getting_Started has not yet been updated for the 0.9 release. It is still the outdated version for the 0.7 release. The work flows have improved a lot since the 0.7 release.

I do know that work is ongoing with the update of the user's guide, see bug 511377 for the tracking of this update.

One tip though that I can see from your screen shot is that you have the advanced mode enabled for the model explorer. Unfortunately the enabling, and especially disabling, advanced mode interferers with the UML-RT specific customizations of the model explorer. So if you do not have a really strong need for using the advanced mode, then I suggest that you do not enable it. The problem will be that if you now disable it, the customization for the protocol for example, will not work as expected.

Two suggestions for you going forward: Wait until the user guide have been updated for the 0.9 release. Check bug 511377 or even subscribe to it for getting notified about when this has been fixed. Then when you do, start with a fresh new workspace, and avoid enabling the advanced mode in the model explorer.

Hope this helps,

/Peter Cigéhn
Re: Papyrus-rt 0.9 Getting_Started: cannot select protocol for port [message #1758507 is a reply to message #1758488] Wed, 29 March 2017 13:01 Go to previous messageGo to next message
Andre Bossert is currently offline Andre BossertFriend
Messages: 5
Registered: February 2016
Junior Member
Hi,

yes i saw the differences in the outdated tutorial, but thought the general workflow is similar and just wanted to start with the latest version. I did not enabled "advanced mode" deliberately Smile so i will try to start again from scratch and first find out how to disable it before defining model elements.
I will also follow the bug 511377.

Thank You!

Regards
Andre
Re: Papyrus-rt 0.9 Getting_Started: cannot select protocol for port [message #1758518 is a reply to message #1758507] Wed, 29 March 2017 14:18 Go to previous messageGo to next message
Peter Cigehn is currently offline Peter CigehnFriend
Messages: 49
Registered: September 2014
Member
Andre Bossert wrote on Wed, 29 March 2017 13:01

yes i saw the differences in the outdated tutorial, but thought the general workflow is similar and just wanted to start with the latest version. I did not enabled "advanced mode" deliberately Smile so i will try to start again from scratch and first find out how to disable it before defining model elements.


Just for the sake of it, I had to try it with the advanced mode enabled (in my own testing I have never tested with the advanced mode enabled since it interferes with the different customizations that are made in the mode explorer), and indeed, when having the advanced mode enabled, the protocols does not show up in the browse dialog when selecting to type a port with an existing protocol.

So if you want to continue using the outdated user guide, and don't have the patience to wait for the update, please try again but make sure to not have the advanced mode enabled in the model explorer! As I recommended before, please start with a fresh workspace so that the model explorer is reset to all its default settings.

I wrote bug 514413 to track this issue with the advanced mode in the model explorer.

Hope this helps.

/Peter Cigéhn
Re: Papyrus-rt 0.9 Getting_Started: cannot select protocol for port [message #1758916 is a reply to message #1758518] Tue, 04 April 2017 14:50 Go to previous messageGo to next message
Charles Rivet is currently offline Charles RivetFriend
Messages: 199
Registered: May 2014
Location: Canada
Senior Member

The updated, v0.9 version of the Getting Started with Papyrus for Real Time Tutorial is now available on the wiki. A PDF version is also available on that page.

Bug 511377 was updated accordingly.

Thank you for your patience.


/Charles Rivet
Re: Papyrus-rt 0.9 Getting_Started: cannot select protocol for port [message #1770012 is a reply to message #1758916] Mon, 07 August 2017 13:56 Go to previous message
Andre Bossert is currently offline Andre BossertFriend
Messages: 5
Registered: February 2016
Junior Member
Thank You! I will give it another try with the released v1.0 :)
Previous Topic:Passive Class with Usermade attribute type
Next Topic:Incrementing time
Goto Forum:
  


Current Time: Tue Sep 18 19:02:31 GMT 2018

Powered by FUDForum. Page generated in 0.02116 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top