Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problems launching Java Eclipse(Getting Fatal error)
Problems launching Java Eclipse [message #1757917] Tue, 21 March 2017 19:58 Go to next message
Alireza Teimoortagh is currently offline Alireza TeimoortaghFriend
Messages: 1
Registered: March 2017
Junior Member
Hi guys,

I just downloaded the zip file for the 32 bit Java Eclipse program. I then unzipped everything to my C:\Users\Alireza folder/directory but for some reason, when I try to run it I get the following message:

Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.

After I hit OK, the picture that I have attached pops up. I have no idea what I did/am doing wrong and why it wont launch. I did not have any problems when I previously had the C++ version of Eclipse installed.

I tried to search this forum but I couldn't really find anything. I appreciate any help I can get to get this up and running.


Thanks!
index.php/fa/28816/0/
  • Attachment: error.jpg
    (Size: 86.21KB, Downloaded 1406 times)
Re: Problems launching Java Eclipse [message #1757934 is a reply to message #1757917] Wed, 22 March 2017 00:30 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4059
Registered: July 2009
Senior Member

There's a lot in that output that mentions requiring Java 1.8. You're trying to run with 1.7. Download and install the latest 64-bit Java Runtime or JDK and try it again.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 22 March 2017 03:36]

Report message to a moderator

Re: Problems launching Java Eclipse [message #1758215 is a reply to message #1757934] Fri, 24 March 2017 18:01 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
To avoid problems like this, you should use the Installer - it's intelligent about finding and using an appropriate JVM and/or directing you to download it if it can't find one on your system.
Previous Topic:Eclipse won't work after a few months of not using it
Next Topic:After upgrading from neon.2 to neon.3, getting NPE in org.eclipse.core.internal.net.ProxyManager
Goto Forum:
  


Current Time: Sun Jun 13 03:31:23 GMT 2021

Powered by FUDForum. Page generated in 0.03085 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top