Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Containment references are not shown in the ecore diagram
Containment references are not shown in the ecore diagram [message #1756197] Mon, 13 March 2017 18:42 Go to next message
Nicolas   is currently offline Nicolas Friend
Messages: 38
Registered: October 2014
Member
Hello everyone,

Sorry if this isn't the proper board, but I want to ask you something, I'm working on an Ecore file using the ecore diagram and I'm having an odd issue, containments are being shown like regular relations (no black diamond at the source), here's an screenshot of one containment (not container), I've also attached the properties of the reference.

Do you know if somehow I turned off those diamonds? I need to export the diagram, but it's useless this way. I've attached the ecore file aswell.
Re: Containment references are not shown in the ecore diagram [message #1756215 is a reply to message #1756197] Tue, 14 March 2017 06:44 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 29539
Registered: July 2009
Senior Member
I think you can change the appearance via the properties in the "Style" tab.
Previous Topic:strange behavior in my dsl editor
Next Topic:[CDO] ClassCastException when setting transaction on a new branch
Goto Forum:
  


Current Time: Thu Sep 20 12:14:22 GMT 2018

Powered by FUDForum. Page generated in 0.10584 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top