Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Papyrus Installation on Ubuntu 16.10(Receiving error messages when trying to install Papyrus)
Papyrus Installation on Ubuntu 16.10 [message #1756108] Sat, 11 March 2017 12:56 Go to next message
Todd Chilson is currently offline Todd ChilsonFriend
Messages: 2
Registered: March 2017
Junior Member
Hello,

I am trying to install Papyrus on Ubuntu 16.10 64 bit. I receive the following error.
I am using the install new software feature with the Work With bar pointing to http://download.eclipse.org/modeling/mdt/papyrus/updates/releases/mars.
What am I doing wrong or is there another way to install this? Thanks in advance.


Cannot complete the install because one or more required items could not be found.
Software being installed: Papyrus UML 1.1.4.201602101200 (org.eclipse.papyrus.sdk.feature.feature.group 1.1.4.201602101200)
Missing requirement: Papyrus Palette Customization 1.1.4.201602101200 (org.eclipse.papyrus.customization.palette 1.1.4.201602101200) requires 'bundle org.eclipse.gmf.runtime.diagram.ui 1.5.0' but it could not be found
Cannot satisfy dependency:
From: Papyrus customization 1.1.4.201602101200 (org.eclipse.papyrus.customization.feature.feature.group 1.1.4.201602101200)
To: org.eclipse.papyrus.customization.palette [1.1.4.201602101200]
Cannot satisfy dependency:
From: Papyrus UML 1.1.4.201602101200 (org.eclipse.papyrus.sdk.feature.feature.group 1.1.4.201602101200)
To: org.eclipse.papyrus.customization.feature.feature.group [1.1.4.201602101200]
Re: Papyrus Installation on Ubuntu 16.10 [message #1756485 is a reply to message #1756108] Fri, 17 March 2017 17:07 Go to previous message
Stephen Blackwell is currently offline Stephen BlackwellFriend
Messages: 138
Registered: March 2014
Senior Member
First off, you would be better posting this to the Papyrus forum. https://www.eclipse.org/forums/index.php/f/121/

Papyrus bug #501314 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=501314) exists for this issue.

An alternative solution is to add Papyrus to the Available Software sites.
Select Help->Install New Software... from the main menu which pops up the "Install" dialog.
Click the "Add..." button which pops up the "Add Repository" dialog.
After much searching I found this site: http://download.eclipse.org/releases/neon/. There is probably a similar one for the Mars release.
Enter this as the Location and Papyrus as the name and press the OK button to dismiss the popup.
Now select the new site from the "Work with" drop down menu, expand the Modeling tree and select "Papyrus UML" from the list.
Click the Next button and the next "Next" button, accept the license and then click the "Finish" button.
Papyrus now installs.
Click the Yes button to restart Eclipse when it is finished.
When Eclipse restarts check that the Papyrus button is displayed in the Toolbar.
Previous Topic:Eclipse jee-neon on macOS Sierra
Next Topic:JavaFX text
Goto Forum:
  


Current Time: Mon Jul 06 06:01:03 GMT 2020

Powered by FUDForum. Page generated in 0.02616 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top