Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Git integration fails(Git integration for Eclipse - auto-import for Eclipse >= 4.6 4.6.0.201612231935-r)
Git integration fails [message #1755041] Mon, 27 February 2017 13:00 Go to next message
Nikolay Ganchev is currently offline Nikolay GanchevFriend
Messages: 2
Registered: February 2017
Junior Member
Unable to install Git integration for Eclipse - auto-import for Eclipse >= 4.6 4.6.0.201612231935-r for my Version: Mars.2 Release (4.5.2)


Cannot complete the install because one or more required items could not be found.
Software being installed: Git integration for Eclipse - auto-import for Eclipse >= 4.6 4.6.0.201612231935-r (org.eclipse.egit.ui.smartimport 4.6.0.201612231935-r)
Missing requirement: Git integration for Eclipse - auto-import for Eclipse >= 4.6 4.6.0.201612231935-r (org.eclipse.egit.ui.smartimport 4.6.0.201612231935-r) requires 'bundle org.eclipse.ui.ide 3.12.0' but it could not be found

Need help to sort it out.

BR
Re: Git integration fails [message #1755079 is a reply to message #1755041] Mon, 27 February 2017 20:46 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 53
Registered: August 2016
Member
The feature is named "Git integration for Eclipse - auto-import for Eclipse >= 4.6".

Eclipse Mars.2 is Eclipse 4.5.2.

As the name implies, this feature cannot be installed on Eclipse Mars.

The rest of the EGit/JGit bundles should work fine with Eclipse Mars.
Re: Git integration fails [message #1755609 is a reply to message #1755079] Mon, 06 March 2017 10:19 Go to previous messageGo to next message
Nikolay Ganchev is currently offline Nikolay GanchevFriend
Messages: 2
Registered: February 2017
Junior Member
Where can I find the old version supported for Eclipse 4.5? I need to use Java7 for my projects and that is why I am not going for Eclipse => 4.6

When I use http://download.eclipse.org/egit/updates-4.5/ it still send me to install "Git integration for Eclipse - auto-import for Eclipse >= 4.6" when the site states it is mend for Eclipse 4.5 and lower...

index.php/fa/28668/0/

[Updated on: Mon, 06 March 2017 10:32]

Report message to a moderator

Re: Git integration fails [message #1755619 is a reply to message #1755609] Mon, 06 March 2017 11:10 Go to previous messageGo to next message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 53
Registered: August 2016
Member
http://download.eclipse.org/egit/updates-4.5/ is the update site for EGit 4.5, not for Eclipse 4.5. EGit 4.5 can be installed on any Eclipse >= 4.2 (Juno).

There is no version of the smartimport feature for Eclipse < 4.6 since it depends on features introduced only with Eclipse 4.6.
Re: Git integration fails [message #1755986 is a reply to message #1755619] Thu, 09 March 2017 19:32 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 962
Registered: July 2009
Senior Member
Find URLs for old releases here
https://wiki.eclipse.org/EGit/FAQ#Where_can_I_find_older_releases_of_EGit.3F
Previous Topic:Dialogue or control for push --set-upstream origin
Next Topic:Very slow git clone performance
Goto Forum:
  


Current Time: Wed Nov 22 20:31:48 GMT 2017

Powered by FUDForum. Page generated in 0.01950 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software