Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » Selecting a list item(Unable to select list items)
icon9.gif  Selecting a list item [message #1754784] Wed, 22 February 2017 11:13
JD ya is currently offline JD yaFriend
Messages: 2
Registered: February 2017
Junior Member
Hi ,

I am trying to automate an rcp based tool. In one of my test cases , I am trying to select an item from a list using steps as below :

get-group "group_Test" | get-list | select "list-item"

but , I keep getting an error that says "Failed to set selection: [[list-item]].".
even though the item is present , I even tried to add a filter so that only the item I want to select is visible .. But still not able to select the items shown in the list .


The swt.info gives the following structure in the the area that I want to select the list item.

Group()
{
Label(Label1)
Label()
Label(Label2)
List()
Button(button1)
Button(button2)
Button(button3)
List()
Button(button4)
Label()
Button(button5)
}

NOTE : The values populated in the list are read from data maintained in another rcp perspective

Can anyone please help me with this issue .



[Updated on: Sat, 25 February 2017 07:47]

Report message to a moderator

Previous Topic:Closing intermittent startup popups without generating errors?
Next Topic:Failed to launch RCPTT runner.
Goto Forum:
  


Current Time: Mon Oct 22 18:47:34 GMT 2018

Powered by FUDForum. Page generated in 0.02152 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top