Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse Mars and Linux Fedora 25
Eclipse Mars and Linux Fedora 25 [message #1754774] Wed, 22 February 2017 09:49 Go to next message
Ben Engbers is currently offline Ben EngbersFriend
Messages: 12
Registered: July 2009
Junior Member
2 Months ago I updated my SamsungNC110 to Fedora 25.
At first look Eclipse Mars seemed to work fine.

Yesterday I had to create a new project and then it showed that when I try to create a new java-project, the dialog in which I can enter a project-name, remains blank.
After switching to Eclipse Luna, creating the project and swithing back to Mars again, I tried to edit the project properties.
In the left column I can click on all the items but the content the screen does not change.

I tried reinstalling Mars (with eclipse-installer) but that didn't help.

Is this a known problem?

Ben
Re: Eclipse Mars and Linux Fedora 25 [message #1754781 is a reply to message #1754774] Wed, 22 February 2017 10:29 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 28981
Registered: July 2009
Senior Member
It's likely a GTK issue. Does resizing the dialog(s) help to make it/themrepaint? Perhaps try adding this before the -vmargs section of the eclipse.ini to force Eclipse to use GTK 2 instead of the default GTK 3:
--launcher.GTK_version
2
If that makes it work, then it's yet another GTK 3 issue...
Re: Eclipse Mars and Linux Fedora 25 [message #1754826 is a reply to message #1754781] Wed, 22 February 2017 19:46 Go to previous message
Andrey Loskutov is currently offline Andrey LoskutovFriend
Messages: 79
Registered: July 2009
Member
May be a stuupid question: Mars is already out-of-service, and we've just about releasing last supported Neon release. Why in the hell are you trying to use Mars and not Neon? There were LOT of GTK 3 fixes in Neon.
Previous Topic:Platform changes not persisted on Mac OS X Sierra 10.12.3
Next Topic:Eclipse NEON SAP BI Modeling issues
Goto Forum:
  


Current Time: Fri Nov 24 18:54:55 GMT 2017

Powered by FUDForum. Page generated in 0.01695 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software