Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » ECLIPSE WONT INSTALL!!(HELP PLEASE!)
icon8.gif  ECLIPSE WONT INSTALL!! [message #1753854] Fri, 10 February 2017 17:52 Go to next message
Shawn Turt is currently offline Shawn TurtFriend
Messages: 1
Registered: February 2017
Junior Member
Hey!

I am trying to install eclipse but it isnt working!

[2017-02-10 18:16:48] Executing bootstrap tasks
[2017-02-10 18:16:48] Java(TM) SE Runtime Environment 1.8.0_121-b13
[2017-02-10 18:16:48] Product org.eclipse.products.epp.package.java.neon
[2017-02-10 18:16:48] Bundle org.eclipse.oomph.setup 1.6.0.v20161125-0947, build=2790, branch=33010448bcf5775ec23e485876cbb07a0340b9b5
[2017-02-10 18:16:48] Bundle org.eclipse.oomph.setup.core 1.6.0.v20161128-0928, build=2790, branch=33010448bcf5775ec23e485876cbb07a0340b9b5
[2017-02-10 18:16:48] Bundle org.eclipse.oomph.setup.p2 1.6.0.v20161019-0656, build=2790, branch=33010448bcf5775ec23e485876cbb07a0340b9b5
[2017-02-10 18:16:48] Performing P2 Director (Eclipse IDE for Java Developers (Neon))
[2017-02-10 18:16:48] Offline = false
[2017-02-10 18:16:48] Mirrors = true
[2017-02-10 18:16:48] Resolving 5 requirements from 3 repositories to C:\Users\Etjan_2\java-neon2\eclipse
[2017-02-10 18:16:48] Requirement epp.package.java [4.6.0,4.7.0)
[2017-02-10 18:16:48] Requirement org.eclipse.platform.feature.group [4.6.0,4.7.0)
[2017-02-10 18:16:48] Requirement org.eclipse.rcp.feature.group [4.6.0,4.7.0)
[2017-02-10 18:16:48] Requirement org.eclipse.jdt.feature.group [3.12.0,3.13.0)
[2017-02-10 18:16:48] Requirement org.eclipse.oomph.setup.feature.group
[2017-02-10 18:16:48] Repository http://download.eclipse.org/technology/epp/packages/neon/M5
[2017-02-10 18:16:48] Repository http://download.eclipse.org/releases/neon/201602051000
[2017-02-10 18:16:48] Repository http://download.eclipse.org/oomph/updates/milestone/latest
[2017-02-10 18:16:48] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/oomph/updates/milestone/latest/compositeContent.xml.
java.net.SocketException: Address family not supported by protocol family: connect
at java.net.DualStackPlainSocketImpl.connect0(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at org.apache.http.conn.scheme.PlainSocketFactory.connectSocket(PlainSocketFactory.java:117)
at org.apache.http.impl.conn.DefaultClientConnectionOperator.openConnection(DefaultClientConnectionOperator.java:177)
at org.apache.http.impl.conn.ManagedClientConnectionImpl.open(ManagedClientConnectionImpl.java:304)
at org.apache.http.impl.client.DefaultRequestDirector.tryConnect(DefaultRequestDirector.java:611)
at org.apache.http.impl.client.DefaultRequestDirector.execute(DefaultRequestDirector.java:446)
at org.apache.http.impl.client.AbstractHttpClient.doExecute(AbstractHttpClient.java:863)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
at org.eclipse.ecf.provider.filetransfer.httpclient4.HttpClientFileSystemBrowser.runRequest(HttpClientFileSystemBrowser.java:263)
at org.eclipse.ecf.provider.filetransfer.browse.AbstractFileSystemBrowser$DirectoryJob.run(AbstractFileSystemBrowser.java:69)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)





What do I do?
Re: ECLIPSE WONT INSTALL!! [message #1754053 is a reply to message #1753854] Tue, 14 February 2017 07:57 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31253
Registered: July 2009
Senior Member
A few people have complained about various problems with accessing this update site. The file http://download.eclipse.org/oomph/updates/milestone/latest/compositeContent.jar exists and p2 should find it. But if some server, network, or network proxy problem prevents that file too from being downloaded, the loading of this site will fail and the stack trace from the first failed access will be displayed. Are you behind a network proxy that you perhaps need to configure (using the menu to access the preferences)?
Previous Topic:Installing plugins overwrites eclipse.ini
Next Topic:Merge Two Eclipse Plugins
Goto Forum:
  


Current Time: Sun Jul 12 07:15:45 GMT 2020

Powered by FUDForum. Page generated in 0.03345 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top