Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Oxygen M5 refuses to update
Oxygen M5 refuses to update [message #1752827] Fri, 27 January 2017 21:30 Go to next message
Frank Benoit is currently offline Frank BenoitFriend
Messages: 136
Registered: July 2009
Senior Member
I did a new install.
However the "check for updates" fails with "no remedy".

Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Platform 4.7.0.v20170126-1030 (org.eclipse.platform.feature.group 4.7.0.v20170126-1030)
  Software currently installed: Eclipse IDE for Java Developers 4.7.0.20161214-1101 (epp.package.java 4.7.0.20161214-1101)
  Only one of the following can be installed at once: 
    Quicklinks for the Welcome Framework 1.0.0.v20170104-1824 (org.eclipse.ui.intro.quicklinks 1.0.0.v20170104-1824)
    Quicklinks for the Welcome Framework 1.0.0.v20160515-0255 (org.eclipse.ui.intro.quicklinks 1.0.0.v20160515-0255)
  Cannot satisfy dependency:
    From: Eclipse IDE for Java Developers 4.7.0.20161214-1101 (epp.package.java 4.7.0.20161214-1101)
    To: org.eclipse.platform.feature.group [4.7.0.v20161208-1309]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.7.0.v20161208-1309 (org.eclipse.platform.feature.group 4.7.0.v20161208-1309)
    To: org.eclipse.ui.intro.quicklinks [1.0.0.v20160515-0255]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.7.0.v20170126-1030 (org.eclipse.platform.feature.group 4.7.0.v20170126-1030)
    To: org.eclipse.ui.intro.quicklinks [1.0.0.v20170104-1824]


How can I analyze this? Is this a bug? Do i have something installed that avoids this update

Was adding the update site: http://download.eclipse.org/eclipse/updates/4.7milestones
the problem?
Re: Oxygen M5 refuses to update [message #1752989 is a reply to message #1752827] Tue, 31 January 2017 17:18 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 788
Registered: January 2012
Senior Member

You can't typically update an EPP package to a milestone build. Yes, if you disable the 4.7milestones (Preferences > Install/Update > Available Update Sites[/em] and uncheck the site) then you should be ok.

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:"unable to retrieve the bundle ..." when Eclipse Neon2 is opening
Next Topic:Reuse keybinding to open another dialog
Goto Forum:
  


Current Time: Mon Nov 19 02:49:23 GMT 2018

Powered by FUDForum. Page generated in 0.02431 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top