Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Compare » Problems using the UI compare with dynamic Ecore models
Problems using the UI compare with dynamic Ecore models [message #1752819] Fri, 27 January 2017 16:24 Go to next message
Kristopher Born is currently offline Kristopher BornFriend
Messages: 5
Registered: December 2012
Junior Member
Hi,

Im facing a problem using the UI of EMF Compare with the instances (.xmi files) of a dynamic Ecore model.

Im using the bank example of EMF Henshin provided here: http://git.eclipse.org/c/henshin/org.eclipse.emft.henshin.git/tree/plugins/org.eclipse.emf.henshin.examples/src/org/eclipse/emf/henshin/examples/bank
When I try to compare example-bank.xmi with example-result.xmi I get problems reported regarding an EClass in the dynamic Ecore model.
I already update my EMF compare version from 3.2.1 to latest version 3.3.0 in hope of an already fixed bug. I also couldn't find information on special issues regarding dynamic ecore models.

Is this already reported as a bug or shall I do so?

Best regards, Kris

index.php/fa/28246/0/
Re: Problems using the UI compare with dynamic Ecore models [message #1752880 is a reply to message #1752819] Mon, 30 January 2017 09:13 Go to previous messageGo to next message
Philip Langer is currently offline Philip LangerFriend
Messages: 83
Registered: March 2015
Location: Vienna, Austria
Member

Hi Kristopher,

please feel free to report a bug with the example models. I haven't used EMF Compare with dynamic models for quite a while. It looks like the metamodel cannot be resolved even though in the models you linked in the Henshin git repo, the schema location seems to be correct. You could also try to register the metamodel in the package registry before the comparison.

Best wishes,

Philip

--
Philip Langer

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/


--
Philip Langer

Get professional Eclipse developer support:
http://eclipsesource.com/en/services/developer-support/
Re: Problems using the UI compare with dynamic Ecore models [message #1753176 is a reply to message #1752880] Thu, 02 February 2017 13:04 Go to previous message
Kristopher Born is currently offline Kristopher BornFriend
Messages: 5
Registered: December 2012
Junior Member
Hello Philip,
thank you for the quick response.

To register the metamodel in the package registry could be a temporary workaround, but I think that shouldn't be an overall solution. I'm afraid that this could lead to a clash when another variant of the metamodel is already installed.
I've opened a bug on this behaviour, see: https://bugs.eclipse.org/bugs/show_bug.cgi?id=511549

Best regards, Kristopher
Previous Topic:Using a custom merger
Next Topic:Compare models structurally equal
Goto Forum:
  


Current Time: Fri Apr 20 11:07:44 GMT 2018

Powered by FUDForum. Page generated in 0.01685 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software