Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error installing Eclipse - Requiring JVM(Installation asking for a JVM that i have)
Error installing Eclipse - Requiring JVM [message #1751754] Fri, 13 January 2017 13:46 Go to next message
EVERSON JUNIOR is currently offline EVERSON JUNIORFriend
Messages: 2
Registered: January 2017
Junior Member
I am trying to install Eclipse on this computer but gives me an error

---------------------------
Incompatible JVM
---------------------------
Version 1.7.0_75 of the JVM is not suitable for this product. Version: 1.8 or greater is required.
---------------------------
OK
---------------------------

Except my java is already up to date. Tried to follow some topics with the same problem, but all of them say to edit eclipse .ini files and so, but I am using the installer .exe, so nothing else to do.

I took a screenshot showing the java version, error and the file i am trying to execute

Thank you!
Re: Error installing Eclipse - Requiring JVM [message #1751756 is a reply to message #1751754] Fri, 13 January 2017 14:14 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3022
Registered: July 2009
Senior Member

That's a 64-bit Eclipse. You'll need to explicitly download and install the 64-bit Java 8.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Error installing Eclipse - Requiring JVM [message #1751875 is a reply to message #1751756] Mon, 16 January 2017 12:06 Go to previous messageGo to next message
EVERSON JUNIOR is currently offline EVERSON JUNIORFriend
Messages: 2
Registered: January 2017
Junior Member
Yes, that solved the problem.

Thank you!
Re: Error installing Eclipse - Requiring JVM [message #1765096 is a reply to message #1751756] Tue, 06 June 2017 14:24 Go to previous messageGo to next message
Ambre SOUBIRAN is currently offline Ambre SOUBIRANFriend
Messages: 1
Registered: June 2017
Junior Member
How and where can I download this? I am a total newbie trying to start learning Java but I have no idea how to fix this! I get the same window telling me that I need a later version of Eclipse... thanks!!
Re: Error installing Eclipse - Requiring JVM [message #1765107 is a reply to message #1765096] Tue, 06 June 2017 17:20 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 29036
Registered: July 2009
Senior Member
If you use the installer, it gives a link to the web page where you can download and install the latest Java SDK. http://www.oracle.com/technetwork/java/javase/downloads/index-jsp-138363.html
Re: Hi [message #1775975 is a reply to message #1751754] Wed, 08 November 2017 17:48 Go to previous messageGo to next message
Bob Ericksen is currently offline Bob EricksenFriend
Messages: 3
Registered: November 2017
Junior Member
I just tried to install eclipse on my Mac running OS X Yosemite 10.10.5 and got the same error that my JVM needs to be updated. I updated to java 8. I didn't see an explicit option for 64bit but the downloaded file said it was 64bit. So I installed it successfully and had the java website confirm I'm running Java 8. But I still get the same error. I've rebooted but still the same error. Any ideas what I do to resolve this? Thank you for your help!
Re: Hi [message #1775979 is a reply to message #1775975] Wed, 08 November 2017 19:33 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3022
Registered: July 2009
Senior Member

Which file did you download? For the Mac, you should install a full JDK and not just a JRE.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Hi [message #1775985 is a reply to message #1775979] Wed, 08 November 2017 21:27 Go to previous messageGo to next message
Bob Ericksen is currently offline Bob EricksenFriend
Messages: 3
Registered: November 2017
Junior Member
Nitin Dahyabhai you were spot on, I only downloaded the JRE, not the full JDK. Downloading the JDK resolved the problem.

Thank you very much!!!
Re: Hi [message #1775986 is a reply to message #1775979] Wed, 08 November 2017 21:28 Go to previous message
Bob Ericksen is currently offline Bob EricksenFriend
Messages: 3
Registered: November 2017
Junior Member
Nitin Dahyabhai you were spot on, I only downloaded the JRE, not the full JDK. Downloading the JDK resolved the problem.

Thank you very much!!!
Previous Topic:Eclipse Error
Next Topic:papyrus extension points
Goto Forum:
  


Current Time: Fri Dec 15 10:31:38 GMT 2017

Powered by FUDForum. Page generated in 0.03267 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software