Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Reference across multiple files not working
Reference across multiple files not working [message #1751664] Thu, 12 January 2017 11:08 Go to next message
Sandeep Joseph is currently offline Sandeep JosephFriend
Messages: 5
Registered: January 2017
Junior Member
Dear All,

I'm very new to XText. I'm following the example mentioned in the Getting Started:

https://www.eclipse.org/Xtext/documentation/102_domainmodelwalkthrough.html

I'm not able to refer the types when I split the code into multiple files. For example, in blog.dmodel I'm not able to use the datatype String, which is declared in datatypes.dmodel.

Could there be some missing things? The documentation says it should work out of the box.

Thanks,
Sandeep
Re: Reference across multiple files not working [message #1751665 is a reply to message #1751664] Thu, 12 January 2017 11:12 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 10598
Registered: July 2009
Senior Member
make sure

- the project has xtext nature (rightklick, configure, convert to xtext project)
- make sure build automatically is on
- the the project is a java project the models should reside in a source folder.
Re: Reference across multiple files not working [message #1751693 is a reply to message #1751665] Thu, 12 January 2017 15:34 Go to previous message
Sandeep Joseph is currently offline Sandeep JosephFriend
Messages: 5
Registered: January 2017
Junior Member
Thanks Christian, The project was not converted to an XText project. Now it works.

Best Regards,
Sandeep
Previous Topic:Keyword Highlighting In A Standalone Application?
Next Topic:XText hook for model transformation?
Goto Forum:
  


Current Time: Tue May 30 12:51:31 GMT 2017

Powered by FUDForum. Page generated in 0.02634 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software