Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Paho » MQTTClient_create(...) C lib problem
MQTTClient_create(...) C lib problem [message #1750787] Wed, 28 December 2016 20:21 Go to next message
Guy Dillen is currently offline Guy DillenFriend
Messages: 16
Registered: January 2014
Junior Member
Hello,

I have some strange behavior. I use the example C code as in https://eclipse.org/paho/clients/c/. It worked before, but now it builds fine but when running I get an exit value -1.073.741.515! Even a simple printf() statement (for debug purposes) in the same code doesn't work.

The statement responsible for this strange error is (I found out by commenting out this statement):
MQTTClient_create(&client, ADDRESS, CLIENTID, MQTTCLIENT_PERSISTENCE_NONE, NULL);

I'm on Windows 10 x64, MinGW compiler and Eclipse Neon + CDT.

Anyone an idea why this code stopped working?

Thanks.
Guy

Re: MQTTClient_create(...) C lib problem [message #1750814 is a reply to message #1750787] Thu, 29 December 2016 10:48 Go to previous message
Guy Dillen is currently offline Guy DillenFriend
Messages: 16
Registered: January 2014
Junior Member
Additional info:
exact the same code works perfectly on my Mac/OS X.
Previous Topic:Set TTL for Mqtt Connection
Next Topic:MQTT client stops sending PINGREQ packets after receiving a message on its subscription
Goto Forum:
  


Current Time: Thu Nov 15 07:02:28 GMT 2018

Powered by FUDForum. Page generated in 0.01600 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top