Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Issue during Eclipse workspace setup
Issue during Eclipse workspace setup [message #1750215] Sun, 18 December 2016 19:37 Go to next message
Eric Salemi is currently offline Eric SalemiFriend
Messages: 34
Registered: September 2016
Location: Belgium
Member
I'm trying to setup the Eclipse workspace for XText.

I'm following the instructions at:

https://github.com/eclipse/xtext/blob/master/CONTRIBUTING.md#set-up-your-eclipse-workspace

Everything goes well until the xtext-umbrella repository is cloned:

Performing Git Clone git@github.com:eclipse/xtext-umbrella.git  (master)
Cloning Git repo git@github.com:eclipse/xtext-umbrella.git to C:\Users\Eric\xtext-master\git\xtext-umbrella
java.lang.Exception: org.eclipse.jgit.api.errors.TransportException: git@github.com:eclipse/xtext-umbrella.git: Auth fail


I'm pretty sure I entered my credentials correctly (User ID have numbers only) and am wondering what I am doing wrong. Down the error message, it seems that oomph tries to clone over git-ssh, and I get confused as to what I should try next.

How are you guys setting the Eclipse workspace?

Btw I'm on Windows 64-bit.

[Updated on: Sun, 18 December 2016 19:38]

Report message to a moderator

Re: Issue during Eclipse workspace setup [message #1750216 is a reply to message #1750215] Sun, 18 December 2016 20:13 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 10574
Registered: July 2009
Senior Member
are you sure you have an ssh key of your machine registered at github.
i have, get asked for may passphrase, and it goes
Re: Issue during Eclipse workspace setup [message #1750217 is a reply to message #1750216] Sun, 18 December 2016 20:22 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 10574
Registered: July 2009
Senior Member
p.s.: can you clone the repo from git bash and or another eclipse?
Re: Issue during Eclipse workspace setup [message #1750233 is a reply to message #1750215] Mon, 19 December 2016 08:08 Go to previous messageGo to next message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 502
Registered: July 2009
Location: Dortmund, Germany
Senior Member

Please let us know if you could fix your issues. I am pretty sure that the setup should work for all repositories.
Re: Issue during Eclipse workspace setup [message #1750269 is a reply to message #1750217] Mon, 19 December 2016 12:08 Go to previous messageGo to next message
Eric Salemi is currently offline Eric SalemiFriend
Messages: 34
Registered: September 2016
Location: Belgium
Member
That is what I did:

1) Create an SSH key with puttygen
2) Install the public key in my Github account
3) Tell Oomph installer to use my private key

And it worked!

It would be nice to update the instructions to mention about the fact that an SSH key is needed. All these steps are not obvious for people who are not coming from the eclipse world.

Now I'm scratching my head as to how I can build the Idea plugin.
Re: Issue during Eclipse workspace setup [message #1750270 is a reply to message #1750269] Mon, 19 December 2016 12:16 Go to previous messageGo to next message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 502
Registered: July 2009
Location: Dortmund, Germany
Senior Member

Thanks Eric,

this will help us to enhance the documentation. I have opened an issue as reminder: https://github.com/eclipse/xtext/issues/1092

We did not recognize this since all of us have already proper GitHub accounts.

~Karsten
Re: Issue during Eclipse workspace setup [message #1753494 is a reply to message #1750270] Tue, 07 February 2017 08:38 Go to previous messageGo to next message
Dariusz Dziuda is currently offline Dariusz DziudaFriend
Messages: 3
Registered: February 2017
Junior Member
Hi,

I also have issues while setting up Eclipse workspace for XText on Fedora 25.

Everything goes well until some time. New eclipse is started. It's being configured, workspace build is started but then there are many compilation errors and error messages like "no more handles". I found out this can be related to GTK3 version but not sure if this is also the cause of compilation errors.

Could someone provide proven working configuration of:
- operating system,
- GTK version,
- options in Eclipse Installer like:
- product version (I tried with Neon),
- jvm (I tried with openjdk 1.8.0),
- target platform (I tried with Neon and Luna),
- any other which may be relevant.

Kind regards,
DD
Re: Issue during Eclipse workspace setup [message #1753566 is a reply to message #1753494] Tue, 07 February 2017 17:47 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 10574
Registered: July 2009
Senior Member
Can you share the .log file of your eclipse/workspace?

I had no problems so far on windows 10, mac and Linux mint
With oracle Jdk and open Jdk (version Cool
Re: Issue during Eclipse workspace setup [message #1753587 is a reply to message #1753566] Tue, 07 February 2017 22:43 Go to previous messageGo to next message
Dariusz Dziuda is currently offline Dariusz DziudaFriend
Messages: 3
Registered: February 2017
Junior Member
log.zip, bak_0.zip, setup.zip with .log, .bak_0.log and setup.log files attached.
  • Attachment: log.zip
    (Size: 10.45KB, Downloaded 14 times)
  • Attachment: bak_0.zip
    (Size: 28.02KB, Downloaded 12 times)
  • Attachment: setup.zip
    (Size: 38.24KB, Downloaded 9 times)

[Updated on: Tue, 07 February 2017 22:54]

Report message to a moderator

Re: Issue during Eclipse workspace setup [message #1753633 is a reply to message #1753587] Wed, 08 February 2017 10:36 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 10574
Registered: July 2009
Senior Member
hmmm i dont really have an idea what this swt error is about
Re: Issue during Eclipse workspace setup [message #1753637 is a reply to message #1753633] Wed, 08 February 2017 11:20 Go to previous messageGo to next message
Dariusz Dziuda is currently offline Dariusz DziudaFriend
Messages: 3
Registered: February 2017
Junior Member
The real issues are (or may be) probably:

!MESSAGE Project org.eclipse.xtext.license.feature exists in different location: /home/ddziuda/eclipse/xtext-master/git/xtext-umbrella/releng/org.eclipse.xtext.license.feature

!MESSAGE Problem parsing archive:file:/!/home/ddziuda/eclipse/xtext-master/git/xtext-xtend/org.eclipse.xtend.maven.android.archetype/src/main/resources/archetype-resources/.project

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtend:org.eclipse.xtend.core:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtext:org.eclipse.xtext.xbase.lib:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtext:org.eclipse.xtext.util:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtext:org.eclipse.xtext.smap:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtend:org.eclipse.xtend.lib:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE Done
!STACK 0
org.xml.sax.SAXException: Done
at org.eclipse.emf.ecore.plugin.EcorePlugin$1Handler.startElement(EcorePlugin.java:383)
at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unknown Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl$NSContentDispatcher.scanRootElementHook(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
at org.eclipse.emf.ecore.plugin.EcorePlugin.computePlatformPluginToPlatformResourceMap(EcorePlugin.java:460)
at org.eclipse.emf.ecore.plugin.EcorePlugin.computePlatformURIMap(EcorePlugin.java:571)
at org.eclipse.xtext.ui.resource.JavaProjectResourceSetInitializer.computePlatformURIMap(JavaProjectResourceSetInitializer.java:60)
at org.eclipse.xtext.ui.resource.JavaProjectResourceSetInitializer.initialize(JavaProjectResourceSetInitializer.java:50)
at org.eclipse.xtext.ui.resource.XtextResourceSetProvider.get(XtextResourceSetProvider.java:51)
at org.eclipse.xtext.builder.impl.XtextBuilder.doBuild(XtextBuilder.java:284)
at org.eclipse.xtext.builder.impl.XtextBuilder.fullBuild(XtextBuilder.java:319)
at org.eclipse.xtext.builder.impl.XtextBuilder.build(XtextBuilder.java:155)
at org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:735)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:206)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:246)
at org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:301)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java:304)
at org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.java:360)
at org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:383)
at org.eclipse.core.internal.resources.Workspace.buildInternal(Workspace.java:487)
at org.eclipse.core.internal.resources.Workspace.build(Workspace.java:399)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$4.run(SetupTaskPerformer.java:3350)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtend:org.eclipse.xtend.core:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtext:org.eclipse.xtext.xbase.lib:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtext:org.eclipse.xtext.util:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtext:org.eclipse.xtext.smap:jar:2.12.0-SNAPSHOT is missing, no dependency information available

!MESSAGE org.eclipse.m2e.core.internal.embedder.EclipseLogger - The POM for org.eclipse.xtend:org.eclipse.xtend.lib:jar:2.12.0-SNAPSHOT is missing, no dependency information available

But github authentication succeeded so I don't know what causes it.

Any hints?
Re: Issue during Eclipse workspace setup [message #1753957 is a reply to message #1753637] Mon, 13 February 2017 11:48 Go to previous message
Karsten Thoms is currently offline Karsten ThomsFriend
Messages: 502
Registered: July 2009
Location: Dortmund, Germany
Senior Member

Please run Maven with profile 'useJenkinsSnapshots' activated. This will enable resolving of 2.12-SNAPSHOT libraries from the Jenkins repositories.
Previous Topic:Reference to files from plugins or projects
Next Topic:Setting up Indigo with Xtext
Goto Forum:
  


Current Time: Sun May 28 03:04:45 GMT 2017

Powered by FUDForum. Page generated in 0.02936 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software