Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Titan » Titan eclipse compilation issues(I am getting many errors compiling my Rel-9 3gpp code with eclipse titan )
icon9.gif  Titan eclipse compilation issues [message #1750097] Fri, 16 December 2016 06:14 Go to next message
siddharth banerjee is currently offline siddharth banerjeeFriend
Messages: 2
Registered: December 2016
Junior Member
I have installed Titan successfully and I am able to execute the hello world test case as well. After that I have imported the 3gpp Rel-9 code but I am getting around 700 errors compiling the same.

The main errors which I am getting are following -->

`omit' value is not allowed in this context

No custom encoding function found for type `@SMS_TypeDefs.CP_PDU_Type'

No coding rule specified for type '@IMS_ASP_TypeDefs.IMS_Request_Type'

Cannot determine the encoding rules for ASN.1 type `@EUTRA-RRC-ASN1-Definitions.DL-CCCH-Message'. No encoding external function found

Cannot determine the decoding rules for ASN.1 type

Cannot determine the encoding rules for ASN.1 type

I have been cleaning, compiling and Restarting eclipse and accidentally it even got compiled once yesterday. But when I restarted eclipse again. Now again I am getting those errors. It would be really helpful if you can help me out here. I have also attached the notepad including all the errors. This code is working fine with testcast. Waiting for help. Thanks in advance.
Re: Titan eclipse compilation issues [message #1750291 is a reply to message #1750097] Mon, 19 December 2016 16:15 Go to previous message
Elemer Lelik is currently offline Elemer LelikFriend
Messages: 807
Registered: January 2015
Senior Member
Hi Siddharth,

thank you for your interest in Titan.


I suggest we go step by step. It would be good if you could send me the package you are trying to compile so I can follow exactly what you are doing.
Please also check in this forum the postings by Murli Sharma, he is also working with 3GPP specs, and so far we managed to solve his problems.

I see two categories of errors : related to omit and related to encoding.

Please edit your Makefile so you have the below compiler flags:

# Flags for the TTCN-3 and ASN.1 compiler:
COMPILER_FLAGS = -L -R -d

-d will tell the compiler to treat default fields as omit. This should get rid of most of your "omit" related errors.


Please also let me know which compiler version you have; "compiler -v" will tell you this.

Best regards

Elemer






Previous Topic:Does Titan support "address" in port?
Next Topic:Titan eclipse giving many compilation issues
Goto Forum:
  


Current Time: Wed Sep 26 14:15:28 GMT 2018

Powered by FUDForum. Page generated in 0.02058 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top