Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Failure in Eclipse installer (Oomph)( trying to setup EGIT/JGIT contribution IDE)
Failure in Eclipse installer (Oomph) [message #1749743] Sat, 10 December 2016 18:39 Go to next message
Francisco Osorio is currently offline Francisco OsorioFriend
Messages: 3
Registered: December 2016
Junior Member
Hi,

I'm trying to setup an IDE for EGIT/JGIT contribution by following the guide at https://wiki.eclipse.org/EGit/Contributor_Guide

After downloading and starting the IDE (Neon), the "perform setup tasks" steps fails because it cannot find javaewah

Missing requirement: JGit Core 4.6.0.v20161210-152719 (org.eclipse.jgit 4.6.0.v20161210-152719) requires 'package com.googlecode.javaewah [1.1.6,2.0.0)'

I tried other versions of the ide (Oxygen and Mars), but I get the same issue.

I could install everything manually I guess, but I thought to report this so people that follow the contributor guide can get an environment easily.

Any advice or workaround will be appreciated.

Thanks,
Francisco

(full log below)

Executing startup tasks
Java(TM) SE Runtime Environment 1.8.0_91-b14
Product org.eclipse.products.epp.package.committers.latest.released
Project org.eclipse.egit.master
Bundle org.eclipse.oomph.setup 1.6.0.v20161125-0947, build=2774, branch=0f3cbae74af4fe94d13c32afb96e9cd4ad2194b7
Bundle org.eclipse.oomph.setup.core 1.6.0.v20161128-0928, build=2774, branch=0f3cbae74af4fe94d13c32afb96e9cd4ad2194b7
Bundle org.eclipse.oomph.setup.git 1.6.0.v20161019-0656, build=2774, branch=0f3cbae74af4fe94d13c32afb96e9cd4ad2194b7
Bundle org.eclipse.oomph.setup.p2 1.6.0.v20161019-0656, build=2774, branch=0f3cbae74af4fe94d13c32afb96e9cd4ad2194b7
Bundle org.eclipse.oomph.setup.pde 1.6.0.v20161019-0656, build=2774, branch=0f3cbae74af4fe94d13c32afb96e9cd4ad2194b7
Bundle org.eclipse.oomph.setup.targlets 1.6.0.v20161019-0656, build=2774, branch=0f3cbae74af4fe94d13c32afb96e9cd4ad2194b7
Bundle org.eclipse.oomph.setup.workingsets 1.6.0.v20161019-0656, build=2774, branch=0f3cbae74af4fe94d13c32afb96e9cd4ad2194b7
Performing Preference /instance/org.eclipse.pde.api.tools/missing_default_api_profile = Warning
Performing Preference /instance/org.eclipse.core.resources/encoding = UTF-8
Performing API Baseline EGit-4.5.0 API Baseline, activate
Unzipping artifacts.jar
Unzipping features/org.eclipse.egit_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.jgit.http.apache_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.egit.gitflow.feature_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.jgit.pgm_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.jgit_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.jgit.source_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.jgit.lfs_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.egit.mylyn_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.jgit.pgm.source_4.5.0.201609210915-r.jar
Unzipping features/org.eclipse.egit.source_4.5.0.201609210915-r.jar
Unzipping index.html
Unzipping plugins/org.kohsuke.args4j_2.0.21.v201301150030.jar.pack.gz
Unzipping plugins/org.eclipse.egit_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.core.source_4.5.0.201609210915-r.jar
Unzipping plugins/org.slf4j.impl.log4j12_1.7.2.v20131105-2200.jar
Unzipping plugins/org.eclipse.egit.gitflow.source_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.jgit.http.apache_4.5.0.201609210915-r.jar
Unzipping plugins/com.google.gson_2.2.4.v201311231704.jar
Unzipping plugins/org.apache.httpcomponents.httpcore_4.3.3.v201411290715.jar
Unzipping plugins/com.jcraft.jsch_0.1.53.v201508180515.jar.pack.gz
Unzipping plugins/org.eclipse.egit.gitflow.ui_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.ui.smartimport_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.ui.source_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.jgit.pgm_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.doc_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.mylyn.ui.source_4.5.0.201609210915-r.jar
Unzipping plugins/org.apache.httpcomponents.httpclient_4.3.6.v201511171540.jar.pack.gz
Unzipping plugins/org.eclipse.jgit_4.5.0.201609210915-r.jar
Unzipping plugins/com.jcraft.jsch_0.1.53.v201508180515.jar
Unzipping plugins/org.eclipse.egit.gitflow_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/com.google.gson_2.2.4.v201311231704.jar.pack.gz
Unzipping plugins/org.eclipse.jgit.archive_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.jgit.source_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.jgit.lfs_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.mylyn.ui_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.jgit.ui_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.doc_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/org.eclipse.egit.ui.smartimport_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/org.apache.httpcomponents.httpcore_4.3.3.v201411290715.jar.pack.gz
Unzipping plugins/org.apache.commons.compress_1.6.0.v201310281400.jar.pack.gz
Unzipping plugins/javaewah_0.7.9.v201605172130.jar
Unzipping plugins/org.apache.log4j_1.2.15.v201012070815.jar
Unzipping plugins/org.eclipse.egit.core_4.5.0.201609210915-r.jar
Unzipping plugins/org.kohsuke.args4j_2.0.21.v201301150030.jar
Unzipping plugins/org.apache.httpcomponents.httpclient_4.3.6.v201511171540.jar
Unzipping plugins/org.eclipse.egit.core_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/org.slf4j.impl.log4j12_1.7.2.v20131105-2200.jar.pack.gz
Unzipping plugins/org.eclipse.egit.ui_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/org.eclipse.jgit.pgm.source_4.5.0.201609210915-r.jar
Unzipping plugins/org.slf4j.api_1.7.2.v20121108-1250.jar
Unzipping plugins/org.apache.log4j_1.2.15.v201012070815.jar.pack.gz
Unzipping plugins/org.eclipse.egit_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/org.eclipse.egit.ui_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.gitflow.ui.source_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.jgit.lfs.server_4.5.0.201609210915-r.jar
Unzipping plugins/org.eclipse.egit.gitflow.ui_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/org.eclipse.egit.mylyn.ui_4.5.0.201609210915-r.jar.pack.gz
Unzipping plugins/org.eclipse.egit.gitflow_4.5.0.201609210915-r.jar
Unzipping plugins/javaewah_0.7.9.v201605172130.jar.pack.gz
Unzipping plugins/org.apache.commons.compress_1.6.0.v201310281400.jar
Unzipping plugins/org.slf4j.api_1.7.2.v20121108-1250.jar.pack.gz
Unzipping content.jar
Unzipping site.xml
Unzipping web/site.css
Unzipping site.properties
Creating API baseline from C:\Users\fo05509\egit-master7\ws\..\api.baseline
Updating build paths
Activating API baseline: EGit-4.5.0
Performing Git Clone https://git.eclipse.org/r/jgit/jgit  (master)
Cloning Git repo https://git.eclipse.org/r/jgit/jgit to C:\Users\fo05509\egit-master7\git\jgit
Receiving objects
...
Setting autocrlf = true
Adding push ref spec: refs/notes/*:refs/notes/*
Adding push ref spec: HEAD:refs/for/master
Creating local branch master
Resetting hard
Performing Git Clone https://git.eclipse.org/r/egit/egit  (master)
Cloning Git repo https://git.eclipse.org/r/egit/egit to C:\Users\fo05509\egit-master7\git\egit
Receiving objects
...
Setting autocrlf = true
Adding push ref spec: refs/notes/*:refs/notes/*
Adding push ref spec: HEAD:refs/for/master
Creating local branch master
Resetting hard
Performing Git Clone https://git.eclipse.org/r/egit/egit-github  (master)
Cloning Git repo https://git.eclipse.org/r/egit/egit-github to C:\Users\fo05509\egit-master7\git\egit-github
Receiving objects
...
Setting autocrlf = true
Adding push ref spec: refs/notes/*:refs/notes/*
Adding push ref spec: HEAD:refs/for/master
Creating local branch master
Resetting hard
Performing Targlets Modular Target (EGit + Eclipse Platform), activate
Repository http://download.eclipse.org/modeling/emf/cdo/orbit/latest-R
Repository http://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.2.13.v20150730
Repository http://download.eclipse.org/technology/swtbot/snapshots
Repository http://download.eclipse.org/mylyn/releases/latest
Repository http://download.eclipse.org/eclipse/updates/4.6
Offline = false
Mirrors = true
Adding repository http://download.eclipse.org/modeling/emf/cdo/orbit/latest-R
Adding repository http://download.eclipse.org/technology/swtbot/snapshots
Adding repository http://download.eclipse.org/mylyn/releases/latest
Adding repository http://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.2.13.v20150730
Adding repository http://download.eclipse.org/eclipse/updates/4.6
Calculating requirements and dependencies.
Cannot complete the request.  Generating details.
ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
  at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:778)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl$4.run(TargletTaskImpl.java:1128)
  at org.eclipse.oomph.util.pde.TargetPlatformUtil.runWithTargetPlatformService(TargetPlatformUtil.java:120)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:1036)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3305)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3248)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4469)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4463)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4461)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3239)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3214)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3114)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:556)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:682)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
  ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1481394443179
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: JGit Core 4.6.0.v20161210-152719 (org.eclipse.jgit 4.6.0.v20161210-152719) requires 'package com.googlecode.javaewah [1.1.6,2.0.0)' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1481394443179
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.jgit [4.6.0,4.6.1)




Re: Failure in Eclipse installer (Oomph) [message #1749819 is a reply to message #1749743] Mon, 12 December 2016 21:52 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 922
Registered: July 2009
Senior Member
Thanks for the heads up. This was fixed by Marc-André
https://git.eclipse.org/r/#/c/86975/
please retry
Re: Failure in Eclipse installer (Oomph) [message #1749869 is a reply to message #1749819] Tue, 13 December 2016 11:49 Go to previous messageGo to next message
Francisco Osorio is currently offline Francisco OsorioFriend
Messages: 3
Registered: December 2016
Junior Member
Thanks Matthias, worked like a charm! Smile

I was planning to add pickaxe functionality to the search bar. Do you have any thoughts/comments on that? Is this being planned for Egit/Jgit?

Thanks again,
Francisco
Re: Failure in Eclipse installer (Oomph) [message #1750089 is a reply to message #1749869] Fri, 16 December 2016 00:32 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 922
Registered: July 2009
Senior Member
Nice, then you should first add pickaxe support to jgit and jgit command line.
AFAIK nobody is working on that at the moment.

pickaxe support is requested here
https://bugs.eclipse.org/bugs/show_bug.cgi?id=457412

the following related bugs ask for grep support
https://bugs.eclipse.org/bugs/show_bug.cgi?id=463481
https://bugs.eclipse.org/bugs/show_bug.cgi?id=443043
Re: Failure in Eclipse installer (Oomph) [message #1750797 is a reply to message #1749743] Thu, 29 December 2016 04:34 Go to previous messageGo to next message
Francisco Osorio is currently offline Francisco OsorioFriend
Messages: 3
Registered: December 2016
Junior Member
Hi Matthias,

Unfortunately the same issue keeps happening when I downloaded the latest installer version (both for neon and oxygen):

Performing Targlets Modular Target (EGit + Eclipse Platform), activate
Repository http://download.eclipse.org/modeling/emf/cdo/orbit/latest-R
Repository http://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.2.13.v20150730
Repository http://download.eclipse.org/technology/swtbot/snapshots
Repository http://download.eclipse.org/mylyn/releases/latest
Repository http://download.eclipse.org/eclipse/updates/4.6
Offline = false
Mirrors = true
Adding repository http://download.eclipse.org/modeling/emf/cdo/orbit/latest-R
Adding repository http://download.eclipse.org/technology/swtbot/snapshots
Adding repository http://download.eclipse.org/mylyn/releases/latest
Adding repository http://download.eclipse.org/eclipse/updates/4.6
Adding repository http://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.2.13.v20150730
Calculating requirements and dependencies.
Cannot complete the request.  Generating details.
ERROR: org.eclipse.equinox.p2.director code=10053 Cannot complete the install because one or more required items could not be found.
  at org.eclipse.oomph.targlets.internal.core.TargletContainer.forceUpdate(TargletContainer.java:778)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl$4.run(TargletTaskImpl.java:1128)
  at org.eclipse.oomph.util.pde.TargetPlatformUtil.runWithTargetPlatformService(TargetPlatformUtil.java:120)
  at org.eclipse.oomph.setup.targlets.impl.TargletTaskImpl.perform(TargletTaskImpl.java:1036)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3305)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3248)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:4469)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2240)
  at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2267)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:4463)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:4461)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3239)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3214)
  at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3114)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:556)
  at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:682)
  at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)
  ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1482980778076
  ERROR: org.eclipse.equinox.p2.director code=0 Missing requirement: JGit Core 4.7.0.v20161229-010610 (org.eclipse.jgit 4.7.0.v20161229-010610) requires 'package com.googlecode.javaewah [1.1.6,2.0.0)' but it could not be found
  ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
    ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1482980778076
    ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.jgit [4.7.0,4.7.1)

Took 456 seconds.
There are failed tasks.


Regards,
Francisco
Re: Failure in Eclipse installer (Oomph) [message #1751719 is a reply to message #1750797] Thu, 12 January 2017 20:15 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 922
Registered: July 2009
Senior Member
I pushed a fix for review
https://git.eclipse.org/r/#/c/88595/
Re: Failure in Eclipse installer (Oomph) [message #1751723 is a reply to message #1751719] Thu, 12 January 2017 21:50 Go to previous message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 922
Registered: July 2009
Senior Member
The fix was submitted, so please try again
Previous Topic:Is there a version of jgit that can run on java 6?
Next Topic:Can't get egit to refresh tag info
Goto Forum:
  


Current Time: Sat May 27 17:38:50 GMT 2017

Powered by FUDForum. Page generated in 0.02656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software