Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse won't start. No Error code!
icon9.gif  Eclipse won't start. No Error code! [message #1749695] Fri, 09 December 2016 19:18 Go to next message
Andrew Elliott is currently offline Andrew ElliottFriend
Messages: 3
Registered: December 2016
Junior Member
Hi, I recently downloaded Eclipse Neon v 1.1. When I first tried to run it it gave me error code 13, so I started researching how to fix it. I found an answer, which was to alter my eclipse.ini. So I did that and then I got another error code, this time it was error code 1. So I researched again. Found an answer, it was to AGAIN alter my eclipse.ini. So I tried it one final time and then something very strange happened... the welcome screen/splash showed up for a split second then went away, I kept trying to run it but the same thing happened. I have been researching for 2 days straight now, no luck. Some other people have had the same problem, but it was a little bit different, the other people have run Eclipse before, so they have their workspaces, but I have never run it before so I don't have much to work with. I have tried reinstalling java and eclipse for the right number of bits (64), but nothing changed.
Here are my eclipse.ini lines:

-startup
plugins/org.eclipse.equinox.launcher_1.3.200.v20160318-1642.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.400.v20160518-1444
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vm
C:\Program Files\Java\jdk1.8.0_111\bin\javaw.exe
-XX:-UseCompressedOops
-vm 
C:\Program Files\Java\jdk1.8.0_111\jre\bin\server\jvm.dll
-vmargs
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m



I need some help right now. I am new to eclipse. Thanks!
Re: Eclipse won't start. No Error code! [message #1749706 is a reply to message #1749695] Fri, 09 December 2016 21:26 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
The first problem I see is that you have the -vm parameter specified twice. Remove one of them (along with the line below with the full path) and try again.

The other thing is, did you use the Eclipse Installer? It does a pretty good job of detecting and configuring a compatible JDK/JRE that it finds on your system.

[Updated on: Fri, 09 December 2016 21:27]

Report message to a moderator

Re: Eclipse won't start. No Error code! [message #1749715 is a reply to message #1749706] Sat, 10 December 2016 00:22 Go to previous messageGo to next message
Andrew Elliott is currently offline Andrew ElliottFriend
Messages: 3
Registered: December 2016
Junior Member
Which one should I remove? And no I haven't where do I find it? Is it the main download at http://eclipse.org/downloads?
Re: Eclipse won't start. No Error code! [message #1749717 is a reply to message #1749706] Sat, 10 December 2016 03:19 Go to previous messageGo to next message
Andrew Elliott is currently offline Andrew ElliottFriend
Messages: 3
Registered: December 2016
Junior Member
I may have been wrong about the version I downloaded. I got the Eclipse IDE for Java Developers. It might still be neon idk XD.
Re: Eclipse won't start. No Error code! [message #1749803 is a reply to message #1749717] Mon, 12 December 2016 14:51 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
In your eclipse.ini try removing these lines:
-vm
C:\Program Files\Java\jdk1.8.0_111\bin\javaw.exe
-XX:-UseCompressedOops


If that doesn't work, get the Installer from www.eclipse.org/downloads (you're correct, the "main" download link/button on that page - you'll know because it's a much smaller download than the packages which are hundreds of MB).
Previous Topic:database connection
Next Topic:Workspace not opening
Goto Forum:
  


Current Time: Wed Sep 19 13:26:06 GMT 2018

Powered by FUDForum. Page generated in 0.02872 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top