Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Flip-Flop Tutorial problem
Flip-Flop Tutorial problem [message #1748957] Wed, 30 November 2016 13:32 Go to next message
Valeriia Iegorova is currently offline Valeriia IegorovaFriend
Messages: 1
Registered: November 2016
Junior Member
Link to the tutorial - https://eclipse.org/4diac/en_help.php

Issue: on clicking "Dowload" button (DEPLOY THE SYSTEM step):
"Major Dowload Error
Resource: FORTE.FlipFlop
MGR_ID: "localhost:61499"
Problem: Connection refused (Connection refused)"

Thanks for any help.
Re: Flip-Flop Tutorial problem [message #1748990 is a reply to message #1748957] Wed, 30 November 2016 20:03 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 523
Registered: January 2014
Senior Member
Normally this means that no runtime environment is running or that your firewall is blocking the access to the runtime environment.

In the "Download" step 4diac-ide tries to open a tcp connection with the selected devices for that it takes the value configured on the device's MGR_ID input. In your case this is localhost:61499. Therefore you need an IEC 61499 runtime (e.g., FORTE) be running which has been configured for this port.

If you are using the runtime launcher view available in the deployment perspective please make sure that you have configured the correct path to the run-times in the 4diac preferences as described in the help.
Previous Topic:Setting up FBRT
Next Topic:Howto use Adapters
Goto Forum:
  


Current Time: Thu May 24 08:24:55 GMT 2018

Powered by FUDForum. Page generated in 0.01656 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top