Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » Slow reaction of Eclipse Editors on a Windows VM(Eclipse Luna vs Eclipse Kepler performance of application)
Slow reaction of Eclipse Editors on a Windows VM [message #1748509] Wed, 23 November 2016 18:20 Go to next message
Yigal Spinner is currently offline Yigal SpinnerFriend
Messages: 109
Registered: July 2009
Senior Member
have an Eclipse application that uses all standard IEditor and Jface tables.
All development and testing is done on Windows 64 bit VM.

During the period that we used Kepler and Java 1.6 we did performance testing for the GUI and we had acceptable results.
Now that we switched to Luna and Java 1.8, the Eclipse application is extremely slower during some period of the day and just slower otherwise. "Slow" means I can see the editor clears the client area and draws the border and then draws the table. When closing the editor I can see the steps Jface is clearing the client area of the window (that may take several seconds) - Yes, that slow. Doing a right Click for a popup menu may take 3-10 seconds to come up and etc.

I did test other application like Notepad, Notepad++, VS2013 at the same time that Eclipse shows slowness, but those applications run fine.
My machine, which is a Windows 2008 R2 Terminal Server, has 24GB memory, 500GB hard drive and 8 CPUs.
I use Java 8, 64 bit, version 101, I'm attaching the eclipse.ini file.
As a side note, when I run the application on a laptop (or any stand alone Desktop), I do not see any performance issues.

Any ideas why Eclipse Luna will perform differently:
1. Using a VM
2. During different periods of the day
3. Why it will be slower then Kepler with Java 1.6

I'll appreciate any approach or direction to help my customers that have the same environment with the same issues. I'm been battling this for a year now.

Thanks Yigal
Re: Slow reaction of Eclipse Editors on a Windows VM [message #1748516 is a reply to message #1748509] Wed, 23 November 2016 21:40 Go to previous message
Dirk Fauth is currently offline Dirk FauthFriend
Messages: 2570
Registered: July 2012
Senior Member
I would try to update to Neon or at least Mars to see if more current versions still show such an error.
Previous Topic:Slow reaction of Eclipse Editors on a Windows VM
Next Topic:How to detect when the result of the canExecute-method method has changed on an already open menu
Goto Forum:

Current Time: Thu Mar 22 07:57:41 GMT 2018

Powered by FUDForum. Page generated in 0.02157 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software