Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » How to set up dev environment for contributions
How to set up dev environment for contributions [message #1747621] Wed, 16 November 2016 14:42 Go to next message
Anders Forsell is currently offline Anders ForsellFriend
Messages: 127
Registered: July 2009
Senior Member
Hi,

I can't find an up-to-date description on how to set up a development environment for the EMF project.

My problem is that I want to add a missing feature in EMF/GWT (https://bugs.eclipse.org/bugs/show_bug.cgi?id=402788) and to be able to build and test it locally.

I have setup the Git/Gerrit part and have access to the source code.

Thanks in advance,

Anders
Re: How to set up dev environment for contributions [message #1747627 is a reply to message #1747621] Wed, 16 November 2016 15:40 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31909
Registered: July 2009
Senior Member
Yes, I saw your contribution this morning. Something in the build failed, which looks completely unrelated to your changes... Did you use advanced mode of Oomph's Eclipse Installer to create/setup your development environment?

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: How to set up dev environment for contributions [message #1747629 is a reply to message #1747627] Wed, 16 November 2016 15:41 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31909
Registered: July 2009
Senior Member
And don't worry about the failed build; that seems unrelated and there are really no tests in the build for GWT. And I have no idea how the run a build locally so you really only have the development environment itself in which you can test...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: How to set up dev environment for contributions [message #1747958 is a reply to message #1747629] Thu, 17 November 2016 10:04 Go to previous message
Anders Forsell is currently offline Anders ForsellFriend
Messages: 127
Registered: July 2009
Senior Member
I managed to set up what seems to be a good dev environment for EMF with Oomph (nice tool!).

I regenerated the Ecore.ecore model with this environment and issued a new Gerrit change https://git.eclipse.org/r/#/c/85196/
(had to abandon the old change due to a Git mistake I did)

The verification still failed but it got much further though...

How do I get the build artifacts from Hudson so I can test the generated emf.gwt plugin manually?

[Updated on: Thu, 17 November 2016 11:02]

Report message to a moderator

Previous Topic:[CDO] Security PackageFilter and ClassFilter
Next Topic:The changeRecorder consolidateChanges does not seem to handle opposite features
Goto Forum:
  


Current Time: Sun Jun 20 05:01:36 GMT 2021

Powered by FUDForum. Page generated in 0.02037 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top