Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Maven Integration for Web Tools Platform » m2e connector build-helper-maven-plugin breaks junit integration(When auto-searching and installing build-helper-maven-plugin junit integration stops working after forced restart)
m2e connector build-helper-maven-plugin breaks junit integration [message #1747401] Mon, 14 November 2016 10:17
Jurrian Hartveldt is currently offline Jurrian HartveldtFriend
Messages: 1
Registered: November 2016
Junior Member
Hi there,

I've tried looking for this issue but haven't been able to find any solution or workaround. Feel free to point it out to me if there is already. With maven usually the plugins are downloaded automatically, but in Eclipse there are m2e connectors. When auto-installing the `build-helper-maven-plugin`, it correctly downloads and installs the version 0.15.0.201207090124.

After installing and restarting eclipse the complete junit integration is broken: The junit windows that were previously open display "Could not create the view: org.eclipse.jdt.junit.ResultView" instead and any runtime configrations are gone (as is the possibility to add junit configurations).

I'm experiencing this issue since the latest version of Eclipse Neon.1 (4.6.1). Neon.RC and Mars.2 worked correctly with the "build-helper-maven-plugin".

Thanks in advance for having a look.
This is my first post on this forum, so please let me know if I'm missing any information that should be provided.

Kind regards,
Jurrian
Previous Topic:Java EE EAR project - Supported by M2E?
Next Topic:Set Maven - User Settings based on windows environment variable
Goto Forum:
  


Current Time: Mon Sep 24 15:02:09 GMT 2018

Powered by FUDForum. Page generated in 0.03600 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top