Skip to main content

Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » How to Install an Earlier Version of libsvn-java (How to install the correct version of Subclipse?)
How to Install an Earlier Version of libsvn-java [message #1747318] Sat, 12 November 2016 01:53
Missing name Mising name is currently offline Missing name Mising nameFriend
Messages: 11
Registered: December 2010
Location: Torrance, CA
Junior Member
I installed the latest version of Eclipse Neon in Ubuntu 16.04.1 LTS . When I attempted to create a PHP project I got this error:

Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = /usr/java/packages/lib/amd64:/usr/lib/x86_64-linux-gnu/jni:/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnu:/usr/lib/jni:/lib:/usr/lib

So I attempted to install JavaHL follow the instructions at:

In Eclipse: Help => Installation Details I see I have Subclipse version 1.10.13. According that web page I need to install SVN/JavaHL version 1.8.x. When I follow the directions farther down that page and execute the command:

sudo apt-get install libsvn-java

what is installed is version 1.9.3-2ubuntu1. How can I install version 1.8.x?

I attempted to install Subclipse version 1.12.x by pasting the URL:

In Eclipse: Help => Install New Software => Work with field, after removing both Subclipse and SVNKit. But the versions it was going to install was still Subclipse 1.10.13 and SVNKit Library 1.8.12.
Previous Topic:Packages
Next Topic:compare with
Goto Forum:

Current Time: Wed Feb 01 16:47:57 GMT 2023

Powered by FUDForum. Page generated in 0.17214 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top