Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Random Errors while build file(Build Problem)
Random Errors while build file [message #1746969] Tue, 08 November 2016 08:11 Go to next message
Mubdiul Hasan is currently offline Mubdiul HasanFriend
Messages: 38
Registered: November 2016
Member

Hi,

In the project properties setting, I am using arm-none-eabi-gcc toolchain.
This time toolchain is Ac6 STM32 MCU GCC and builder CDT internal.

Problem is if I add h files in HAL library that error log suggest me to do, it solved and if I build project again it shows the problem in CMSIS include H files. Embarrassed

Such as,

1. C:\STM32_toolchain\common\Drivers\CMSIS\Device\ST\STM32F0xx\Include/stm32f0xx.h:187:3: error: declaration for parameter 'FunctionalState' but no such parameter
} FunctionalState;
^
..\inc\Src\stm32f0xx_hal_flash_ex.c:990:1: error: expected '{' at end of input
}
^
..\inc\Src\stm32f0xx_hal_flash_ex.c:990:1: warning: control reaches end of non-void function [-Wreturn-type]
}
^
How to solve it? Shocked
Re: Random Errors while build file [message #1746983 is a reply to message #1746969] Tue, 08 November 2016 10:57 Go to previous messageGo to next message
David VavraFriend
Messages: 1413
Registered: October 2012
Senior Member
The error isn't random. It's being caused by a syntax error.
-Missing punctuation can cause it.
-A strange but unprintable character can cause it.
-A malformed declaration can cause it.
- this is unlikely an inclusive list

As I said before, it can be hard to track down the actual cause.
You can try removing pieces of code until you find where the problem area lies.
Or maybe better: start with small pieces and keep adding until the error reappears.

Yes, it can be frustrating but the question is off topic here as it is not a CDT problem.




Re: Random Errors while build file [message #1747053 is a reply to message #1746983] Wed, 09 November 2016 00:32 Go to previous message
Mubdiul Hasan is currently offline Mubdiul HasanFriend
Messages: 38
Registered: November 2016
Member

Dear Sir Devid,

Thank you once again.
Even I worked MCU coding for 2 years, it looks things are going much complex if you want to do something new. Still I am newcomer in this area! Shocked


My company gave me a reference code to develop, It has a main file with hundreds of supporting HAL header and c.

APIs, Headers,state machine files are exists in Project branch, but why the compiler showing errors in H files of driver ?

Looking at your C code structure related reason, yes I found some style of C coding in CMSIS h files is different.

I tried to build this file in COOCOX, its fine in errors but build fails due to,

C:\Users\swend95_하산\Desktop\Old_rice_cooker\Source_bak\common\Drivers\CMSIS\Device\ST\STM32F0xx\Source\Templates\gcc does not exist.

It might tell something about s files or directory that I cant solve.

In ecilipse what should I do now?

1. CDT does not showing errors of my main files, there was a return type problem, I solved it.

3. I think compiler is compiling all files listed in project branch , do you want me to remove some of the files from project folder, is it repeating again as I include paths from C driver?

4. Is there any setting for which only compile my c file?

5. Do you believe, updated version of Java/gcc/Eclipse is needed ?
I am using this HAL driver STM32Cube_FW_F0_V1.6.0 downloaded from STM website.


Hope you will give me some good suggestions.

Regards
HASAN
Previous Topic:Open declaration/EnclosingASTNameJob hangs
Next Topic: random data & access
Goto Forum:
  


Current Time: Sun Jan 23 02:29:06 GMT 2022

Powered by FUDForum. Page generated in 0.01853 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top