Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Problem with hibernate instalation and dependencies
Problem with hibernate instalation and dependencies [message #1746936] Mon, 07 November 2016 20:38 Go to next message
Justyna Bie is currently offline Justyna BieFriend
Messages: 1
Registered: November 2016
Junior Member
HI, I would like to install hibernate tools from http:// download.jboss.org /jbosstools/updates/stable/helios, however I cant because I have following problem:

Cannot complete the install because of a conflicting dependency.
Software being installed: JBoss Maven Hibernate Configurator 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.hibernate.feature.feature.group 1.2.0.v20111027-1501-H240-Final)
Software currently installed: m2e-wtp - Maven Integration for WTP 1.3.1.20160831-1005 (org.eclipse.m2e.wtp.feature.feature.group 1.3.1.20160831-1005)
Only one of the following can be installed at once:
Maven Integration for Eclipse WTP 0.13.0.20110623-0455 (org.maven.ide.eclipse.wtp 0.13.0.20110623-0455)
This version of m2e-wtp cannot be installed on top of the already installed m2eclipse-wtp. Uninstall the previous version of m2eclipse-wtp and try the install again. 1.3.1.20160831-1005 (org.maven.ide.eclipse.wtp 1.3.1.20160831-1005)
Maven Integration for Eclipse WTP 0.13.1.20110728-1800 (org.maven.ide.eclipse.wtp 0.13.1.20110728-1800)
Maven Integration for Eclipse WTP 0.13.1.20110718-1012 (org.maven.ide.eclipse.wtp 0.13.1.20110718-1012)
Cannot satisfy dependency:
From: m2e-wtp - Maven Integration for WTP 1.3.1.20160831-1005 (org.eclipse.m2e.wtp.feature.feature.group 1.3.1.20160831-1005)
To: bundle org.maven.ide.eclipse.wtp [1.3.1.20160831-1005]
Cannot satisfy dependency:
From: JBoss Maven Core 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.core 1.2.0.v20111027-1501-H240-Final)
To: bundle org.maven.ide.eclipse.wtp [0.13.0,0.15.0)
Cannot satisfy dependency:
From: JBoss Maven Hibernate Configurator 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.hibernate 1.2.0.v20111027-1501-H240-Final)
To: bundle org.jboss.tools.maven.core 0.0.0
Cannot satisfy dependency:
From: JBoss Maven Hibernate Configurator 1.2.0.v20111027-1501-H240-Final (org.jboss.tools.maven.hibernate.feature.feature.group 1.2.0.v20111027-1501-H240-Final)
To: org.jboss.tools.maven.hibernate [1.2.0.v20111027-1501-H240-Final]

index.php/fa/27523/0/

I use Eclipse Neon. Please help me because I was trying to remove Eclipse and install it again and nothing can celp me.
  • Attachment: hiberror.JPG
    (Size: 59.12KB, Downloaded 153 times)
Re: Problem with hibernate instalation and dependencies [message #1747015 is a reply to message #1746936] Tue, 08 November 2016 15:04 Go to previous message
Stephan Herrmann is currently offline Stephan HerrmannFriend
Messages: 1528
Registered: July 2009
Senior Member
Installing software intended for Eclipse Helios (2010) into Eclipse Neon (2016) doesn't sound like a healthy exercise.

Please either find a newer version from jboss or find their forum to ask your question.
Previous Topic:Problem to start Neon
Next Topic:Compiler error with IBM Java
Goto Forum:
  


Current Time: Sat Nov 25 02:02:24 GMT 2017

Powered by FUDForum. Page generated in 0.01570 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software