Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse 4 » SWT Browser
SWT Browser [message #1745766] Mon, 17 October 2016 10:23 Go to next message
Jean-Pascal Laux is currently offline Jean-Pascal LauxFriend
Messages: 38
Registered: December 2011
Member
Hello

I have noticed a change/bug in SWT Browser.
I used an AuthenticationListener to provide credentials.
In the listener, I check the event.location to choose the correct credential.
The code was written for Eclipse 3.7 and works fine with this version. With Neon, event.location is always null.

The workaround is to use a LocationListener.

The other problem I have is request headers. I would like to add a specific header, so I use browser.setUrl(url,null,headers) but It does not work.

Jean-Pascal

[Updated on: Mon, 17 October 2016 10:24]

Report message to a moderator

Re: SWT Browser [message #1745812 is a reply to message #1745766] Mon, 17 October 2016 18:19 Go to previous message
Brian de Alwis is currently offline Brian de AlwisFriend
Messages: 655
Registered: January 2012
Senior Member

I'd suggest filing a bug for each problem. Please specify details about which operating system you see this on, and provide a small standalone example that clearly demonstrates the problem. http://httpbin.org is a great testing resource. You can use 'https://httpbin.org/basic-auth/user/passwd' for your authentication case, and 'https://httpbin.org/get' as the URL to verify the request headers. (http://requestb.in is very handy too.)

Brian.


Eclipse Platform committer. Ask me about Eclipse support, training, and consulting.
Previous Topic:How to disable MenuItems from Fragment
Next Topic:SWT - Creating child context in ShellActivationListener
Goto Forum:
  


Current Time: Tue Sep 26 09:25:08 GMT 2017

Powered by FUDForum. Page generated in 0.03284 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software