Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Vorto » [SOLVED]Unresolved requirement in Vorto IDE for contributor(Clean installed the Yatta profile and tried to start a code generator project as Eclipse app)
[SOLVED]Unresolved requirement in Vorto IDE for contributor [message #1745728] Sun, 16 October 2016 17:29 Go to next message
Nyiri András is currently offline Nyiri AndrásFriend
Messages: 14
Registered: September 2016
Junior Member
Hello,
I'm new to Vorto, and after trying out javabean and web application generator from the tutorial I thoght it's time to getting to know more about the works of the code generator projects.
So I installedthe Vorto IDE for contributor profile with Yatta. After it finished the building of the workspace I tried to run the 'org.eclipse.vorto.codegen.examples.javabean' project as an Eclipse application. When it's starting it prints several errors to the console like this one:
!ENTRY org.eclipse.vorto.editor.ui 4 0 2016-10-16 19:13:18.471
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.vorto.editor.ui [534]
  Unresolved requirement: Require-Bundle: org.eclipse.vorto.core.ui
    -> Bundle-SymbolicName: org.eclipse.vorto.core.ui; bundle-version="0.9.0.qualifier"; singleton:="true"
       org.eclipse.vorto.core.ui [518]
         Unresolved requirement: Require-Bundle: org.apache.commons.collections

	at org.eclipse.osgi.container.Module.start(Module.java:434)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

After scrolling throw the errors similar like this it seems like the root cause is an unresolved requirement 'org.apache.commons.collections'. Can anyone help me with this?

EDIT:
It looks like selecting an other target platform solved this. Go to Window > Preferences... > Plug-in Development > Target Platform, then select 'target-definitions /org.eclipse.vorto.targetplatform/vorto.target'.

[Updated on: Sun, 16 October 2016 17:40]

Report message to a moderator

Re: [SOLVED]Unresolved requirement in Vorto IDE for contributor [message #1745857 is a reply to message #1745728] Tue, 18 October 2016 12:57 Go to previous messageGo to next message
Alexander Edelmann is currently offline Alexander EdelmannFriend
Messages: 35
Registered: January 2015
Member
Hello Nyiri,

you did everything right, namely setting your eclipse installation to the target platform manually. At the moment, the yatta script does not do this automatically, I am afraid.

If you would like to go through the vorto tutorial, you can simply install the Vorto toolset from our update site or the Eclipse Marketplace.
You can find more details about that on our website under Downloads:
https://www.eclipse.org/vorto/downloads/index.html

The yatta script actually sets up an eclipse and installs all bundles for contributing to the Vorto project itself. Not sure, if you intending to do that at the moment or just trying out the toolset?

If you need further assistance, do not hesitate to contact me.

Alex
Re: [SOLVED]Unresolved requirement in Vorto IDE for contributor [message #1745958 is a reply to message #1745857] Wed, 19 October 2016 20:25 Go to previous message
Nyiri András is currently offline Nyiri AndrásFriend
Messages: 14
Registered: September 2016
Junior Member
Hello,
I'm already did most of the tutorials with Vorto, I'm just looking into the code generators as I might modify some things for my education. Maybe write a new generator.
Also I've had some exceptions thrown while trying Vorto as a plugin with Eclipse Neon, but in the run-time eclipse from this development environment everything looks smoother Smile .

Thanks,
Andrew
Previous Topic:Java Build Error
Next Topic:Importing files into Vorto Project
Goto Forum:
  


Current Time: Tue Sep 18 20:03:23 GMT 2018

Powered by FUDForum. Page generated in 0.02081 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top