Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Strategy for fixing installation for buildship upgrade problem?
Strategy for fixing installation for buildship upgrade problem? [message #1745704] Fri, 14 October 2016 20:29
David M. Karr is currently offline David M. KarrFriend
Messages: 575
Registered: July 2009
Senior Member
My workspace and installation (neon.1) has been having an issue with attempting to install an update to the Buildship plugin. I've asked about this on the Gradle forum, but they're unable to recommend a solution. I've had this issue for a few weeks now. I suppose it's possible that simply reinstalling would fix this, but I'd like to be able to fix my installation, instead of just giving up and starting over.

I currently have version 1.0.18.v20160817-1550 installed.

When I check for updates, it tells me that version 1.0.21.v20161010-1640 is available (it's curious that right-clicking on the available entry and selecting "Copy" doesn't put this into my clipboard, I had to manually enter that version number here).

When I attempt to install this, I get the following:
An error occurred while collecting items to be installed
session context was:(profile=C__Users_dk068x_eclipse_java-neon_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,com.gradleware.tooling.client,0.16.0.v20160831165132
No repository found containing: osgi.bundle,com.gradleware.tooling.model,0.16.0.v20160831165132
No repository found containing: osgi.bundle,com.gradleware.tooling.utils,0.16.0.v20160831165132
No repository found containing: osgi.bundle,org.eclipse.buildship.branding,1.0.21.v20161010-1640
No repository found containing: osgi.bundle,org.eclipse.buildship.core,1.0.21.v20161010-1640
No repository found containing: osgi.bundle,org.eclipse.buildship.stsmigration,1.0.21.v20161010-1640
No repository found containing: osgi.bundle,org.eclipse.buildship.ui,1.0.21.v20161010-1640
No repository found containing: org.eclipse.update.feature,org.eclipse.buildship,1.0.21.v20161010-1640
No repository found containing: osgi.bundle,org.gradle.toolingapi,2.14.1.v20160831165132


I occasionally run into errors like this with other plugins. In many of those cases, I've been able to uninstall the existing plugin and attempt to install it fresh, and that fixes this problem. This strategy isn't working for a curious reason that probably has something to do with the fact that Buildship apparently "comes with" Neon.

When I uninstall buildship and restart Eclipse, I immediately look at the "Installation Details" page and I do see that Buildship isn't there. However, if I look at the dialog again after Eclipse finishes its restart process, I see that the version 1.0.18 version has returned, even though I uninstalled it.

I then went to the "Install New Software" dialog and searched for "Buildship" in several update sites. For some reason, I have several update sites for "Neon", being the following:



I didn't manually add these, so I'm not sure exactly why they're all here.

By checking each one, I found that all of the "date-stamped" ones had a version of Buildship available. The oldest one had the 1.0.15 version, and the other two had the 1.0.18 version. I then unchecked the checkbox for all of them, and then I went to the "Installation Details" page and uninstalled Buildship again. I restarted, and after a minute, Buildship 1.0.18 reappeared in the "Installation Details" page. I then checked the update sites again, and I saw that the last "201610111000" site, was now checked again.

Not sure what I can do here.
Previous Topic:Asking for confirmation before closing an editor
Next Topic:GTK+3 with eclipse 4.5
Goto Forum:
  


Current Time: Tue Sep 18 14:14:36 GMT 2018

Powered by FUDForum. Page generated in 0.01991 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top