Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Arduino Upload and Board Support Packages(Arduino Upload and Board Support Packages)
icon5.gif  Arduino Upload and Board Support Packages [message #1745633] Thu, 13 October 2016 15:43 Go to next message
Lance Brooks is currently offline Lance BrooksFriend
Messages: 10
Registered: October 2016
Junior Member
Hi -

Hoping someone can help me get upload to work with my board -- or perhaps please help me learn how Board Support Packages are described in the Eclipse C++ IDE for Arduino so I can find the error in my setup or the BSP itself.

I have other Arduino boards working great with the Eclipse IDE. The board I am having trouble with works with the classic Arduino IDE. So, I know in general things are working.

The board with the problem is an Adafruit Pro Trinket 5V/16 MHz (USB). I am trying to use the USBtinyISP Programmer.

When I try to upload, I get a Problem Occurred dialog that says: "'Launching StopWatch' has encountered a problem. Upload command not specified".

I searched through the various configuration files for the board and found the following:

In .arduinocdt\packages\adafruit\hardware\avr\1.4.9\boards.txt:

# Pro-Trinket 5V USB Programming Configuration
protrinket5.name=Pro Trinket 5V/16MHz (USB)
protrinket5.bootloader.tool=arduino:avrdude
protrinket5.build.mcu=atmega328p
protrinket5.build.f_cpu=16000000L
protrinket5.build.core=arduino:arduino
protrinket5.build.variant=arduino:eightanaloginputs
protrinket5.build.board=AVR_PROTRINKET5
protrinket5.upload.tool=arduino:usbtiny
protrinket5.upload.maximum_size=28672
protrinket5.upload.speed=115200


In .arduinocdt\packages\arduino\hardware\avr\1.6.14\programmers.txt:

usbtinyisp.name=USBtinyISP
usbtinyisp.protocol=usbtiny
usbtinyisp.program.tool=avrdude
usbtinyisp.program.extra_params=


In .arduinocdt\packages\arduino\tools\avrdude\6.3.0-arduino6\etc\avrdude.conf:

programmer
  id    = "usbtiny";
[SNIPPED LINK]
  type  = "usbtiny";
  connection_type = usb;
  usbvid     = 0x1781;
  usbpid     = 0x0c9f;
;


In .arduinocdt\packages\adafruit\hardware\avr\1.4.9\platform.txt:

tools.avrdude.upload.params.verbose=-v
tools.avrdude.upload.params.quiet=-q -q
tools.avrdude.upload.pattern="{cmd.path}" "-C{config.path}" {upload.verbose} -p{build.mcu} -c{upload.protocol} -P{serial.port} -b{upload.speed} -D "-Uflash:w:{build.path}/{build.project_name}.hex:i"


NOTE: I do not think the following is involved, but maybe it shows one that works.

In .arduinocdt\packages\arduino\hardware\avr\1.6.14\platform.txt

tools.avrdude.upload.params.verbose=-v
tools.avrdude.upload.params.quiet=-q -q
tools.avrdude.upload.params.noverify=-V
tools.avrdude.upload.pattern="{cmd.path}" "-C{config.path}" {upload.verbose} {upload.verify} -p{build.mcu} -c{upload.protocol} -P{serial.port} -b{upload.speed} -D "-Uflash:w:{build.path}/{build.project_name}.hex:i"


How do these files/settings map to the Upload dialog error?

Appreciate any help. Have a great day!
Re: Arduino Upload and Board Support Packages [message #1745689 is a reply to message #1745633] Fri, 14 October 2016 15:00 Go to previous messageGo to next message
Doug Schaefer is currently offline Doug SchaeferFriend
Messages: 135
Registered: July 2009
Senior Member
The recommendation I usually give is to try this with the official Arduino IDE. If it works there and not with Eclipse then I know I have a bug somewhere.

I have some recollection that usbtiny is actually broken in the Arduino IDE as well. But I may be mixing that up with another board.
Re: Arduino Upload and Board Support Packages [message #1745696 is a reply to message #1745689] Fri, 14 October 2016 16:14 Go to previous messageGo to next message
Lance Brooks is currently offline Lance BrooksFriend
Messages: 10
Registered: October 2016
Junior Member
Hi - Thanks for the reply. Yes, exactly. I made sure it works with the Arduino IDE first: it is working well and I am on the same PC too -- so same driver, board, cable. Also, my other Arduino boards are working with the Eclipse IDE, so those pipes seem to be flowing OK. It is the combination of Adafruit Pro Trinket and USBtinyISP that is giving me fits.

I want to help as much as I can. Since the error said "Upload command not specified", it seemed like maybe a metadata issue. But I have no clue because I am not familiar with how the configuration files manifest themselves into the implementation. I would love to be pointed to reference material to learn more so I can dig in and help. Otherwise, I am most appreciative of any assistance.

Have a great day/weekend!!
Re: Arduino Upload and Board Support Packages [message #1745807 is a reply to message #1745696] Mon, 17 October 2016 16:11 Go to previous message
Lance Brooks is currently offline Lance BrooksFriend
Messages: 10
Registered: October 2016
Junior Member
Hello again - I submitted the following bug:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=506098

Please let me know how I can help -- if possible. Thank you.
Previous Topic:How a MBSCustomPage instance can get current toolchain ?
Next Topic:How can I change the default value of a compiler option ?
Goto Forum:
  


Current Time: Sat Jan 29 05:50:34 GMT 2022

Powered by FUDForum. Page generated in 0.02304 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top