Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Debug toolbar display issue(Debug toolbar does not want to show in Debug perspective)
Debug toolbar display issue [message #1745041] Tue, 04 October 2016 12:33 Go to next message
Bernard Gautier is currently offline Bernard GautierFriend
Messages: 11
Registered: May 2011
Junior Member
I am using Neon (CDT) on Ubuntu 14.04 and recently I did an update of Eclipse. CDT is now on version 9.1.0.201609121658.
Unfortunately, since then, when debugging my application (remote application on a embedded system), the Debug toolbar is not displayed anymore.
And even after enabling it via Customize Perspective (through Action Set Availability), it works once but not for next debug session. And for the next sessions it is even not possible to enable it again.
I am getting this error message in Error Log: (see attached file)
Plug-in 'org.eclipse.cdt.ui' contributed an invalid Menu Extension ...

Don't know if it is related.

Is it a bug or are there some changes with latest version of CDT?



  • Attachment: cdtdebug.log
    (Size: 3.33KB, Downloaded 70 times)

[Updated on: Tue, 04 October 2016 12:35]

Report message to a moderator

Re: Debug toolbar display issue [message #1745044 is a reply to message #1745041] Tue, 04 October 2016 12:46 Go to previous messageGo to next message
Jonah Graham is currently offline Jonah GrahamFriend
Messages: 404
Registered: June 2014
Senior Member
Hi Bernard,

Sorry to hear you are having a problem.

I am not sure what the issue is, but perhaps something has gone wrong in the perspective. Have you tried resetting the perspective (Window -> Perspective -> Reset Perspective)?

I am pretty sure the logged items don't have anything to do with the problem and are probably a side effect of the work ongoing to update project wizards (if you could file a bug about that separate issue it that would be useful.) The reason it is probably not related is that the majority of the debug toolbar is provided by the Eclipse Platform, not CDT itself.

Let us know how you get on, and hopefully someone else will have a more detailed suggestion if reset does not work.

Jonah
Re: Debug toolbar display issue [message #1745338 is a reply to message #1745044] Fri, 07 October 2016 14:22 Go to previous message
Bernard Gautier is currently offline Bernard GautierFriend
Messages: 11
Registered: May 2011
Junior Member
Hello Graham,

Thanks for your support.
Yes, I tried resetting the perspective but it did not help. Issue was still here.

In the end, I downloaded NEON.1 and did a fresh install. This solved the issue.
Debug tool bar is now shown and I have no more error messages.

I don't know why but the update from NEON to NEON.1 did not work perfectly.
Previous Topic:Eclipse Neon - Remote C/C++ Project Setup
Next Topic:HOWTO use AVRA to assemble AVR ASM *.S files
Goto Forum:
  


Current Time: Fri Jan 28 09:47:29 GMT 2022

Powered by FUDForum. Page generated in 0.02249 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top