Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Missing Requirement for Teneo when Creating RAP .target File
Missing Requirement for Teneo when Creating RAP .target File [message #1744965] Mon, 03 October 2016 13:26 Go to next message
Eric Domeshek is currently offline Eric DomeshekFriend
Messages: 10
Registered: October 2016
Junior Member
I'd appreciate some help with my attempt to get started with RAP. I am trying to define a .target platform file that includes EMF, Teneo, and Hibernate. I am getting the following error (seems to be the root among a related set of errors):

"Missing requirement: EMF Teneo 2.1.0v2016... requires 'bundle org.eclipse.emf.common [2.7.0,3.0.0)' but it could not be found.

I could not find an up-to-date update site for EMF, so I ended up downloading the latest, unzipping it, and having my new .target file access it as a directory (which it seems to be seeing OK). That directory includes the org.eclipse.emf.common (2.12.0v20160420-0247). So it's unclear to me why Teneo says it can't find the dependency it needs.

Here is the current state of my .target file [NOTE: In the XML below, I had to eliminate all "http" due to the first-time poster forum filter, so I changed them all to "hllp"]:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde version="3.8"?><target name="rap-emf-teneo" sequenceNumber="8">
<locations>
<location path="/Users/domeshek/Documents/Workspaces/Neon-2016/RAP-EMF-Teneo-Target/emf-xsd-Update-2.12.0" type="Directory"/>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.rap.equinox.target.feature.feature.group" version="3.1.1.20160912-1200"/>
<unit id="org.eclipse.rap.sdk.feature.feature.group" version="3.1.1.20160831-0710"/>
<unit id="org.eclipse.rap.examples.feature.feature.group" version="3.1.1.20160831-0700"/>
<unit id="org.eclipse.rap.feature.feature.group" version="3.1.1.20160831-0710"/>
<repository location="hllp://download.eclipse.org/rt/rap/3.1/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.emf.teneo.hibernate.sdk.feature.group" version="2.1.0.v201602010922"/>
<unit id="org.eclipse.emf.teneo.hibernate.feature.group" version="2.1.0.v201602010922"/>
<repository location="hllp://download.eclipse.org/modeling/emf/teneo/updates/2.1.0/interim/"/>
</location>
<location includeAllPlatforms="false" includeConfigurePhase="true" includeMode="planner" includeSource="true" type="InstallableUnit">
<unit id="org.hibernate.feature.group" version="4.1.1.201310261216"/>
<unit id="org.hsqldb.feature.group" version="2.2.8.201310261216"/>
<unit id="com.db4o.feature.group" version="7.4.155.v20120928-1733"/>
<unit id="org.apache.log4j.feature.group" version="1.2.16.201310261216"/>
<unit id="org.dom4j.feature.group" version="1.6.1.201310261216"/>
<unit id="org.apache.commons.logging.feature.group" version="1.1.1.201310261216"/>
<unit id="org.postgresql.feature.group" version="9.0.0.201310261216"/>
<unit id="com.mysql.jdbc.feature.group" version="5.1.11.201310261216"/>
<unit id="javax.persistence.feature.group" version="2.0.1.201310261216"/>
<unit id="com.microsoft.sqlserver.jdbc.feature.group" version="3.0.1301.201310261216"/>
<repository location="hllp://www.elver.org/eclipse/2.0.0/update/"/>
</location>
</locations>
</target>


Anyone have any suggestions as to what I'm doing wrong?

Thanks,

--Eric
Re: Missing Requirement for Teneo when Creating RAP .target File [message #1745000 is a reply to message #1744965] Tue, 04 October 2016 03:25 Go to previous messageGo to next message
Chris Fairhall is currently offline Chris FairhallFriend
Messages: 197
Registered: February 2011
Senior Member
If the EMF plugin is available, perhaps it's dependencies are not.
After you've started the application, type "ss" in to the console to list the current bundles
If you see the bundle there and it's not ACTIVE, try and start it with "start <bundle id>"
That might give you more information as to why it's failing to start.
Re: Missing Requirement for Teneo when Creating RAP .target File [message #1745058 is a reply to message #1745000] Tue, 04 October 2016 16:26 Go to previous message
Eric Domeshek is currently offline Eric DomeshekFriend
Messages: 10
Registered: October 2016
Junior Member
Thanks for your suggestion. I did manage to sort this out late yesterday (at least I think I did... for now).

First, I found the EMF plugins available from the Neon modeling site.

Then after much struggle I found a forum post somewhere that suggested unchecking the "Include required software" box on the "Add Content" wizard. That seemed to do the trick, as I stopped getting a zillion different and constantly changing failed dependency errors.

My remaining concern is that it will turn out that I did, in fact, need some of those required software packages after all, and I'll only find out by suffering through another blizzard of dependency bugs.

But I got my initial demo running, so that's progress.
Previous Topic:RichTextEditor and images
Next Topic:Using TypeScript for custom widget ?
Goto Forum:
  


Current Time: Sat May 26 04:35:32 GMT 2018

Powered by FUDForum. Page generated in 0.03074 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top