Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » Create p2 repo that includes RAP
Create p2 repo that includes RAP [message #1744028] Wed, 21 September 2016 14:12 Go to next message
Mickael Istria - away until August 14th is currently offline Mickael Istria - away until August 14thFriend
Messages: 830
Registered: July 2009
Location: Grenoble, France
Senior Member

Hi,

I'm evaluating the possibility to build the simulataneous release with Tycho. I have an issue regarding RAP:

Quote:

[ERROR] Cannot resolve project dependencies:
[ERROR] Software being installed: Oxygen raw:0.0.1.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):0.0.1-SNAPSHOT
[ERROR] Missing requirement: org.eclipse.emf.rap.feature.group 2.12.0.v20160526-0356 requires 'A.PDE.Target.Platform Cannot be installed into the IDE 0.0.0' but it could not be found
[ERROR] Cannot satisfy dependency: Oxygen raw:0.0.1.'SNAPSHOT'/format(n[.n=0;[.n=0;[-S]]]):0.0.1-SNAPSHOT depends on: org.eclipse.emf.rap.sdk.feature.group [2.12.0.v20160526-0356]
[ERROR] Cannot satisfy dependency: org.eclipse.emf.rap.sdk.feature.group 2.12.0.v20160526-0356 depends on: org.eclipse.emf.rap.feature.group [2.12.0.v20160526-0356]
[ERROR]


Do you know how can this org.eclipse.emf.rap feature can be included into a p2 repo with Tycho? As the publisher uses a planner/director rather than a slicer/mirror (which is great as planning add some very useful dependency validation), how can I deal with this fake dependency?
Re: Create p2 repo that includes RAP [message #1744148 is a reply to message #1744028] Thu, 22 September 2016 17:46 Go to previous messageGo to next message
Mickael Istria - away until August 14th is currently offline Mickael Istria - away until August 14thFriend
Messages: 830
Registered: July 2009
Location: Grenoble, France
Senior Member

Here is the general context: https://bugs.eclipse.org/bugs/show_bug.cgi?id=500769#c4
Re: Create p2 repo that includes RAP [message #1744356 is a reply to message #1744028] Mon, 26 September 2016 09:50 Go to previous message
Markus Knauer is currently offline Markus KnauerFriend
Messages: 147
Registered: July 2009
Senior Member

The full answer is in my comment on the bug at https://bugs.eclipse.org/bugs/show_bug.cgi?id=500769#c6

The short version: This artificial requirement has been replaced by negative p2 requirements in 2012 in the RAP Runtime project. Up to then it was used to prevent the installation of RAP Runtime features into a running IDE.

At the moment it is only in use by the EMF projects. I would suggest to ask them to remove it if possible.

Regards,
Markus


--

Twitter: @mknauer23 and @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:Accessing JNDI resources from RAP
Next Topic:How to Set WebClient.PAGE_OVERFLOW Property in RAP with Workbench Setup?
Goto Forum:
  


Current Time: Sat Aug 18 08:54:42 GMT 2018

Powered by FUDForum. Page generated in 0.01865 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top