Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Oomph installs aren't working with Eclipse 4.7 I-builds
Oomph installs aren't working with Eclipse 4.7 I-builds [message #1742694] Tue, 06 September 2016 16:36 Go to next message
Stefan Xenos is currently offline Stefan XenosFriend
Messages: 5
Registered: July 2009
Junior Member
The version of Eclipse installed by the Oomph installer off of the Eclipse website isn't working with Eclipse 4.7 integration builds. Specifically, this update site:

http://download.eclipse.org/eclipse/updates/4.7-I-builds/

Unfortunately, this means that Eclipse committers can't use Oomph anymore since it only works with versions of Eclipse that are much too old... so everyone is basically back to using unreliable manual setups again.

I've filed a bug report here:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=500481

If we could get the assistance of someone from the Oomph team, that would be greatly appreciated.
Re: Oomph installs aren't working with Eclipse 4.7 I-builds [message #1742700 is a reply to message #1742694] Tue, 06 September 2016 16:57 Go to previous messageGo to next message
Patrik Suzzi is currently offline Patrik SuzziFriend
Messages: 91
Registered: June 2010
Location: Urdorf, Switzerland
Member

I just saw the same for JSDT installer, but my error ends with:

ERROR: org.eclipse.equinox.p2.director code=0 You requested to install 'workspace_requirements [1.0.0]' but it could not be found


I commented your bug 500481 adding the above details.

Note: according to this old post looks like this is a temporary problem caused by Eclipse servers.

Re: Oomph installs aren't working with Eclipse 4.7 I-builds [message #1742708 is a reply to message #1742700] Tue, 06 September 2016 18:22 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6487
Registered: July 2009
Senior Member
I think I had the same problem. It went away when I manually deleted the old profile (which still contained the workspace_requirements IU) of the targlet container from p2's profile registry. You'd have a similar effect when you change the contents of one of the targlets of that targlet container because that would create and use a new profile with a different ID.

Re: Oomph installs aren't working with Eclipse 4.7 I-builds [message #1743543 is a reply to message #1742708] Fri, 16 September 2016 09:39 Go to previous message
Patrik Suzzi is currently offline Patrik SuzziFriend
Messages: 91
Registered: June 2010
Location: Urdorf, Switzerland
Member

I solved by editing Targlets in the .setup, by changing the update site of a repository from an I-build to an R-build.

Thanks.
Previous Topic:Why oomph plugins versions from 1.5 become 1.4?
Next Topic:Revert to Previous Configuration list is missing in eclipse
Goto Forum:
  


Current Time: Thu Apr 02 00:33:30 GMT 2020

Powered by FUDForum. Page generated in 0.02094 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top